This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by khalidA-23 1 year ago.

Assigned support staff: Lauren.

Author Posts
October 9, 2018 at 4:43 am #2798238

khalidA-23

I am trying to: Change the Arabic language flag image.

Link to a page where the issue can be seen: hidden link

I expected to see: Done

Instead, I got: Blank screen

October 9, 2018 at 2:38 pm #2800517

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Please try renaming the image that you are trying to upload. Perhaps there is a problem with it having the same name as the default flag?

If that does not work, please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

1. Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

2. Browse to the page with the issue and/or reproduce the issue.

3. Locate the debug log in: /wp-content/debug.log

4. Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

October 9, 2018 at 4:36 pm #2801143

khalidA-23

I followed your instructions and did all steps. But, it did not produce any error log file on the same location. What should I do now?

October 9, 2018 at 4:37 pm #2801149

khalidA-23

First, I renamed the image but it did not work. Then, I enabled the debug mode and still does not work.

October 9, 2018 at 5:26 pm #2801417

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Could you please try sending me the flag image so that I can test installing it on a fresh install? That way I can try and determine if it's an issue with the image, or perhaps a conflict on your site. You can attach it in your next reply or upload it to Google Drive/Dropbox and share the download link. Thanks!

October 10, 2018 at 5:41 am #2802966

khalidA-23

attached

October 10, 2018 at 1:13 pm #2804373

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending me the file. I was able to upload the image as a language switcher flag in a fresh install. Feel free to login and take a look here:
Login: hidden link
Username: demo
Password: 1Ql9BeC1roL3

Since I was unable to reproduce on a clean install, we need to troubleshoot your site a bit more. I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentySeventeen. With these settings, is the issue resolved?

October 14, 2018 at 4:03 am #2815062

khalidA-23

I don't know how to disable all plugins. Do I need to activate them one by one in Plugins area?

October 15, 2018 at 1:18 pm #2817648

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Yes please. First make a full backup of your site. Then, go to Plugins and select all plugins other than WPML and in the bulk actions drop down, select deactivate. Then see if you are able to upload the flag. If so, you can then reactivate the plugins one at a time and see if any issues appear.

Please let me know how this goes.

October 15, 2018 at 4:46 pm #2818346

khalidA-23

I did the same instructions. I took a full backup for files and database. Then, I activated the default WP theme. Then, I deactivated all plugins in bulk except WPML plugins. After that, I tried to upload the flag image.. But, nothing happened. It is the same.

October 15, 2018 at 5:47 pm #2818484

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Still no errors in the debug log? Can you please contact your hosting provider and ask them to check the server logs? Perhaps something there will give some insight. Also, maybe they have restrictions on file uploads?

October 16, 2018 at 2:36 am #2819335

khalidA-23

Okay.. forget about it. I am the hosting administrator. This website on my VPS. But, this issue is a small issue I thought it can be solved easily. Okay forget it.

October 16, 2018 at 5:14 pm #2821965

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

If you would like, I could create a copy of your site locally to continue troubleshooting. You could make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it. If you prefer me to stop troubleshooting, you may mark this ticket as resolved.

October 17, 2018 at 7:06 am #2823454

khalidA-23

Please enable the private reply !!!

October 17, 2018 at 4:17 pm #2825316

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

The next reply is marked as private. You may need to refresh your browser to see the private fields. Thanks!