This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 8 months, 1 week ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
February 4, 2019 at 10:57 pm #3159573

Ron

I am trying to: Connect an existing page to translations

Link to a page where the issue can be seen: hidden link

I expected to see: The dropdown show me the Home Page

Instead, I got: Incorrect home pages (old)

February 5, 2019 at 1:14 am #3159717

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

February 5, 2019 at 7:34 pm #3163535

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I took a look in your staging website and couldn't notice the issue, it seems to be caused by a cache issue, I see you are currently using the WP Fastest Cache plugin which is not in our list of compatible plugins as you can see at: https://wpml.org/documentation/plugins-compatibility/?wpv_view_count=119945&dev=0&wpv-plugin-functionality=0&wpv_post_search=WP+Fastest+Cache&wpv_filter_submit=Search. As a possible solution I would recommend:

1 - In your WordPress Dashboard > WPML > Languages > Language filtering for AJAX operations check the option 'Store a language cookie to support language filtering for AJAX' it was a fix suggested in the ticket: https://wpml.org/forums/topic/fastest-cache-wpml/ where the customer had a similiar issue.

2 - If it doesn't work, then I recommend you to change to a compatible cache plugin, this one is a good and popular choice: https://wpml.org/documentation/plugins-compatibility/optimize-multilingual-website-performance-using-w3-total-cache/

Please, let me know if you need any additional clarifications from our side. Have a nice day.

February 6, 2019 at 1:14 am #3163831

Ron

I have followed all of your instructions, including changing the cache plugin. The issue I still face is to connect the "home" pages of the different languages to the english home page. For instance, I wish to tell the WPML to connect this page: hidden link

To this page: hidden link

When I changed the cache plugin, our main page (above) became screwed up.

February 6, 2019 at 8:31 pm #3167574

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Sorry I had missed your points from my first ticket interaction, based on the ticket title 'The language switcher' I assumed you were having issues with the language switcher from your website header which seems to be working as it should, at the other hand you are missing some concepts here, let me explain:

1 - In your WordPress Dashboard > Pages you have a page called 'Home 2019' defined as your homepage.

2 - There's no translation for the 'Home 2019' page, instead you created separated homepages from the different languages and hardcoded the homepage urls using the WordPress menu system from your WordPress Dashboard > Appearance > Menus

Based on the points above you don't need to connect translations as you have connected all you homepages in the header language menu using custom urls and because the fact you don't have translations for you homepage. The recommeded workflow for translating pages built with the Divi builder is described at: https://wpml.org/documentation/theme-compatibility/divi-builder/.

I also reverted back to the WP Fastest plugin as your cache choice since the W3 Total Cache CSS and JS minification feature is not working properly in your server environment.

Please, let me know if you need any additional clarifications. Have a nice day.

February 10, 2019 at 6:27 pm #3180107

Ron

Marcos, There may be a bug in the system.

1) When I attempted to connect The French home page to the English version, the drop down would not show the English home page as an option.

2) However, when I attempt to connect the Italian and Spanish home pages to the English home page, it worked just fine.

February 11, 2019 at 6:28 pm #3184931

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. As explained above, there's no bug, you are trying to connect pages created independently instead of linking page translations.

I took a look in your WordPress Dashboard and could see you have spanish and italian translations for your english homepage, but there's no any french translation as you can (see in the attached screenshot).

Instead of creating pages in different languages, you should add them as translation, this way you don't need to manually try to connect it, also it will be better for SEO purposes, this is the way WPML works when dealing with multilingual website, as mentioned in my previous reply you can find the right way of doing things at: https://wpml.org/documentation/theme-compatibility/divi-builder/.

Hope it helps, have a nice day.