This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Mihai Apetrei 5 months, 1 week ago.

Assigned support staff: Mihai Apetrei.

Author Posts
May 6, 2019 at 11:59 am #3748077

Antoni

When I'm logged in the web backend, wordpress, the language switcher it works, but when I acces to the frontend as a public user it doesn't works, instead the list view it does.

Link to a page where the issue can be seen:
hidden link

May 6, 2019 at 5:23 pm #3751469

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

1. Can you please elaborate a bit more (if you can attach a screenshot, that would be great) about what you mean when you say "instead the list view it does"?

2. Also, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

May 7, 2019 at 11:46 am #3757461

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Can you please follow the steps below:

- Please create a full backup of the site first -

1.

- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

2. If it still happening, I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased as the minimum requirement for WPML is 128Mb WP Memory Limit: https://wpml.org/home/minimum-requirements/

❌ Very important: please make a backup of your site (files & database) before following any of the upcoming steps ❌

Please add this to your wp-config.php file to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so, if that’s the case, I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

Now see if the issue is still happening.

3. If the issue is still happening, I will need you to please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

In order to do that, edit the wp-config.php file inside your WordPress directory and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

Now please reproduce the issue.

Locate the debug log in: /wp-content/debug.log

If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way, because sometimes the logs are long and create a complete mess in discussion).

I will be waiting for your response.

Kind regards,
Mihai

May 7, 2019 at 12:48 pm #3757891

Antoni

Hello Mihai,

I see that elementor pro is the problem. When I deactivated it I can see two switch language selectors, I think one is from the theme...
Also I changed the memory limit in the wp-config file and this is the link to the debug file, it expires in one week: https://pastebin.com/LHWXC26y

Thanks

May 7, 2019 at 4:02 pm #3760217

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the feedback.

I am happy to hear that we are making progress.

By looking at the comments here (hidden link - attached screenshot), it seems that this is a known issue for a long time now regarding the dropdown WPML language switcher and this theme.

However, by looking here (hidden link), it seems that they are working on this in the present and that you should get in touch with the theme support regarding this issue.

Also, I can see an Elementor update available here (hidden link) so maybe it would be good to first do a website back up and then update the Elementor plugin, too, however that might not change the behavior as the issue might be with the theme itself.

Can you please get in touch with the theme support and let me know how the process is going and if they give you any working solution?

This information might be very helpful and vital for other people that might use the exact same theme.

I will be waiting for your response.

Thank you very much.

Kind regards,
Mihai

May 10, 2019 at 7:07 am #3781829

Antoni

Hello Mihai,

Sure, I i give you a feedback from the theme support when the problem was solved.
For now I deactivated Elementor Pro, and the switcher it works, but we loose some useful features.

Thanks

May 10, 2019 at 1:23 pm #3784839

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you very much for the update!

I will then leave this ticket assigned to you for the moment and I will wait to hear from you as soon as you will get an answer from the theme support.

Thank you.

Kind regards,
Mihai

The topic ‘[Closed] The language switcher doesn't work but the list it does’ is closed to new replies.