Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 3 voices.

Last updated by Vincenzo 2 years, 3 months ago.

Assigned support staff: Vincenzo.

Author Posts
November 15, 2017 at 10:21 am

Daniel Grau Olalla

I am trying to:

Configure the language switcher but I think is bugged, I have a flag on my menu but it have an internal link to one of my pages and don't switch the language

Link to a page where the issue can be seen:

hidden link

I expected to see:

The other languages when I hover the flag

Instead, I got:

A redirection to one of my internal pages

November 16, 2017 at 12:17 pm #1432597

Daniel Grau Olalla

Hi,

Waiting assistance,

Thanks

November 16, 2017 at 4:41 pm #1433025

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hello Daniel,

Welcome to WPML support forum.

Please apologize for the delay in answering. This is not usual in this forum. While one of my teammates takes care of your case I will provide you with the first debugging steps.

I visited your site and I could replicate the issue. So far, I see that the pages are translated, however, there is a cool effect that makes pop-up your submenus that is not happening for your language switcher as it is pointing to another page and override by it.

1. Could you go to WPML > Languages > Menu language switcher, and set it as a List of languages? Does it work this time? Then, set it back as a dropdown, what happens this time?

2. On your test site, please check if this issue appears when:
- Only WPML plugins are activated. It will tell us if there is an interaction issue with other plugin.
- Theme is set to a WordPress default like Twenty Fourteen. Its will tell us if there is an interaction issue with your theme.
- If the problem disappears, start activating one at the time to track where the incompatibility is produced.

Let us know if it helps.
Andrés

November 17, 2017 at 8:47 am #1433500

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello there,

my name is Vincenzo and I will take care of this ticket.

Can you please tell me the results of the steps suggested by Andrés?

Please let me know if you need help or more details about those tests.

Thank you

November 17, 2017 at 9:34 am #1433578

Daniel Grau Olalla

Hi vincenzo, I answer for steps:

1. switched to list of languages, it doesn't make any change, like the flag of the menu is not responding to the wpml plugin configuration

2. No plugins interaction issue but with twenty seventeen theme it works correctly

we'll wait for your answer,
Regards

November 17, 2017 at 6:17 pm #1434305

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

I visited your site and I can see that the language switcher is working correctly.

Can you please confirm that the issue with the language switcher is fixed?

Thank you

November 20, 2017 at 9:37 am #1435457

Daniel Grau Olalla

Hi vincenzo,

We can't see the language switcher on our menu but the plugin is activated and configured,

Can you check it please?

Thanks!

November 20, 2017 at 6:04 pm #1436226

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

I am not able to login to the backend because I get this error:

ERR_TOO_MANY_REDIRECTS

I am enabling a private answer so you can share with me the details to access the backend.

In the meantime, please try these steps:
1. Save the Permalinks in Settings -> Permalinks

2. Check the Front page display settings in Settings -> Reading
- Are there any notices or errors on that page?
- Have you set a static front page?

Thank you

November 20, 2017 at 6:40 pm
November 20, 2017 at 7:02 pm #1436296

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

I think the issue may be caused by the fact that the homepage is not translated.

Can you please translate the homepage and try again to see if the language selector will show the correct link?

Thank you

Related documentation:
https://wpml.org/documentation/translating-your-contents/

November 23, 2017 at 10:31 am #1439060

Daniel Grau Olalla

Hello,

Here's the translated pages:

hidden link
hidden link
hidden link

Now we have the language switcher but the links are incorrect, we have french, catalan and english but the switcher only shows catalan language and bad URL,

How is working the ftp and backend acces?
Maybe I will need your IP and country for give you acces through our firewall

November 23, 2017 at 10:39 am #1439069

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

at the moment my IP address is 79.36.91.105 and the country is Italy.

Please let me know when I can try again to access the backend.

In the meantime, can you please try to delete any kind of server or plugin cache?
Sometimes there is some sort of cache also in the theme's options.

Try also to temporarily enable the footer language selector in WPML -> Language to see if the issue is just with the language selector in the menu.

Thank you

November 24, 2017 at 1:00 pm #1440410

Daniel Grau Olalla

Hi,

Your country has been added on backend firewall and the IP on the FTP firewall, now you can try to acces,

Aswell for the moment the language switcher works correctly so is not going to be necessary, but, when we make any change on the menu or on the wpml plugin config, the language switcher crashes, please, don't close the ticket because maybe we will need support again in a few days.

For the moment is working

November 24, 2017 at 2:50 pm #1440594

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

I'm glad to know that your main issue is solved.

I will wait a few days for the final confirmation.

Thank you