Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

All of the known issues are documented in https://wpml.org/known-issues/ you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described here https://wpml.org/faq/checklist-before-opening-a-ticket-in-wpml-support/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by miguel-angelM-7 2 weeks, 6 days ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
March 22, 2019 at 6:55 pm #3443781

miguel-angelM-7

Tell us what you are trying to do?
I´m installing the plugin and after the configuration, only the label of the default language is displayed.

Is there any documentation that you are following?
Yes, I´m following the documentation from the woocommerce template.

Is there a similar example that we can see?
Not at all.

What is the link to your site?
hidden link

March 22, 2019 at 8:04 pm #3444063

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Before a more detailed look, please, try this basic troubleshooting:

1 - Make sure your server environment meets our minimum requirements as described at: https://wpml.org/home/minimum-requirements/, you can see your current values at your WordPress Dashboard > WPML > Support > Info menu.

2 - Disable all the plugins except the WPML related ones from your WordPress Dashboard > Plugins and see if the issue is gone, if so, activate one plugin at a time untill the culprit one is found.

3 - If the issue persists, temporary change to a default WordPress theme such as the 'TwentySeventeen' theme from your WordPress Dashboard > Appearance > Themes menu.

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

Please, let me know if the steps above help to fix your issue. Have a nice day.

March 25, 2019 at 11:54 am #3453007

miguel-angelM-7

Good morning,

I´ve tried all the asked troubleshooting and is still working wrongly.

The requirements are ok, I disabled all the plugins and changed to the default theme, and still the languages were not displaying.

March 25, 2019 at 5:37 pm #3456855

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

March 25, 2019 at 7:30 pm #3457773

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. Please, make sure to provide the access with admin privelleges, otherwise I am not able to check some settings in your WordPress install such as plugins, themes and others. A private reply is enabled for you again, so, you can resend these details safely. Thank you for your collaboration, have a nice day.

March 25, 2019 at 7:39 pm #3457787

miguel-angelM-7

The access remains the same but as an administrator instead of an editor.

Thank you.

March 26, 2019 at 1:53 am #3458951

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the details. I took a detailed look both in your WordPress Dashboard and in your website frotend and couldn't notice any issue with the languages. Can you please provide us with some more info where the issue happen and how to replicate it? Thank you for your collaboration, have a nice day.

March 26, 2019 at 10:12 am #3461255

miguel-angelM-7

You can see the switcher in each option of the meu, one is displayed and the other not

March 26, 2019 at 6:36 pm #3465623

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I took a closer look in your website and noticed you still don't have any translation for your homepage, that's the reason the language switcher doesn't work the secondary languages (see attached screenshot). Please, make sure to add translations for your homepage as well, exactly as you did with your shop pages.

See: https://wpml.org/documentation/getting-started-guide/

Please, let me know if you need any additional detail. Have a nice day.

March 30, 2019 at 1:49 pm #3498623

miguel-angelM-7

My issue is resolved now. Thank you!