This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by emmanuelA-6 1 month, 3 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
August 26, 2019 at 7:24 pm

emmanuelA-6

I am trying to: Setup a menu witcher

Link to a page where the issue can be seen: admin dashboard

I expected to see: Languages Setup

Instead, I got: HTTP ERROR 500

August 27, 2019 at 12:19 am #4461797

emmanuelA-6

How long the support team responses to the tickets?

August 27, 2019 at 9:48 am #4464583

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello there,

Kindly apologize for the delay, This is quite unusual our subsequent responses will be much faster.

500 error can be due to various reason, It would be good if you can provide me with the WordPress debug.log (not WPML debug information).

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:


define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

In this case, the errors will be saved to a debug.log log file inside the /wp-content/ directory.

If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in the discussion).

Also please share the server error logs which is different from the WordPress debug logs.

Kind regards
Raja

August 29, 2019 at 9:30 pm #4483591

emmanuelA-6

Thanks Raja,

I don't have this line (define(‘WP_DEBUG’, false);) in my wp-config.php,

Is there another way to enable the debug option?

Thanks again
Emmanuel

August 30, 2019 at 7:39 am #4485117

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Not an issue, please add these two lines in wp-config.php before the line
/* That's all, stop editing! Happy blogging. */

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Once added try to reproduce the error check if you can find anything in the debug log /wp-content/debug.log

August 30, 2019 at 9:26 pm #4489203

emmanuelA-6

Hi Raja, this is the debug.log contains:

[30-Aug-2019 19:23:42 UTC] Mixed content fixer succesfully detected
[30-Aug-2019 20:25:23 UTC] Mixed content fixer succesfully detected
[30-Aug-2019 21:20:47 UTC] <b>Detecting configuration</b>
[30-Aug-2019 21:20:47 UTC] Opening testpage to check server configuration: hidden link
[30-Aug-2019 21:20:47 UTC] test page url, enter in browser to check manually: hidden link
[30-Aug-2019 21:20:47 UTC] SSL test page loaded successfully
[30-Aug-2019 21:20:50 UTC] <br><b>SSL Configuration</b>
[30-Aug-2019 21:20:50 UTC] testing htaccess rules...
[30-Aug-2019 21:20:50 UTC] test page url, enter in browser to check manually: hidden link
[30-Aug-2019 21:20:50 UTC] htaccess rules tested successfully.
[30-Aug-2019 21:20:50 UTC] checking if .htaccess can or should be edited...
[30-Aug-2019 21:20:50 UTC] .htaccess does not contain default Really Simple SSL redirect
[30-Aug-2019 21:20:50 UTC] retrieving redirect rules
[30-Aug-2019 21:20:50 UTC] converting siteurl and homeurl to https
[30-Aug-2019 21:20:56 UTC] Mixed content fixer could not be detected: cURL error
[30-Aug-2019 21:20:56 UTC] Mixed content fixer could not be detected: cURL error
[30-Aug-2019 21:21:01 UTC] Mixed content fixer succesfully detected
[30-Aug-2019 21:21:08 UTC] <b>Detecting configuration</b>
[30-Aug-2019 21:21:10 UTC] <br><b>SSL Configuration</b>
[30-Aug-2019 21:21:10 UTC] testing htaccess rules...
[30-Aug-2019 21:21:10 UTC] test page url, enter in browser to check manually: hidden link
[30-Aug-2019 21:21:10 UTC] htaccess rules tested successfully.
[30-Aug-2019 21:21:10 UTC] checking if .htaccess can or should be edited...
[30-Aug-2019 21:21:10 UTC] .htaccess does not contain default Really Simple SSL redirect
[30-Aug-2019 21:21:10 UTC] retrieving redirect rules
[30-Aug-2019 21:21:10 UTC] converting siteurl and homeurl to https
[30-Aug-2019 21:21:11 UTC] Mixed content fixer succesfully detected
[30-Aug-2019 21:21:12 UTC] retrieving redirect rules
[30-Aug-2019 21:23:09 UTC] Mixed content fixer succesfully detected

August 30, 2019 at 9:37 pm #4489299

emmanuelA-6

My issue is resolved now. Thank you!