Please make sure to update to WPML to the latest and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 29 replies, has 2 voices.

Last updated by sandraW-3 1 month ago.

Assigned support staff: Yvette.

Author Posts
December 29, 2019 at 3:33 pm

sandraW-3

Hello!

I ran into a weird issue. The layout set in the editor for the global widget does not translate on the life page (see CTA at the bottom hidden link , background should be white and the text centered). Elementor support thinks that this is linked to WPML.

Actually the post grid at the top is not displaying properly either compared to the homepage hidden link

Running Astra free and the latest Elementor Pro version, no caching as on dev.

Please note that my memory limit is set to 256M and not to 40M as displayed in WPML settings (see attachement).

Thanks a lot and have a great day.

December 30, 2019 at 5:46 pm #5212641

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

1. I would have to take a closer look at the backend of your site. Could you please provide username/password with admin priveleges so that I can take a look at the widget and how it is being used?

I am opening the private area for this info.

2. Could you also please create a new English page (not translated) that just contains this single global widget? e.g. it is a standalone page and not a translation.
Does the widget still show incorrectly?
please send link to this new sample page.

Thanks

December 31, 2019 at 9:14 am
December 31, 2019 at 1:26 pm #5216139

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

This does not seem to be related to global widgets.
When I remove the widgets from the page and create another blank page in FR, you can already see the difference in the styling (see images).

Can you check with Elementor support where the default styling is defined that would affect this area that is different?

We can then focus on making sure that setting is also appearing in the EN language space.

December 31, 2019 at 2:22 pm #5216303

sandraW-3

Hello,

Actually, I added the grey background so that you can seen the missing white background. Should have done it in both language.

Therefore, we need to continue to search for the source of the issue...

December 31, 2019 at 3:44 pm #5216553

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

OK - please do keep both languages as similar as possible. Can you please remove the grey background?

Thanks

December 31, 2019 at 4:11 pm #5216575

sandraW-3

Here it is. I redid it and trashed the old version.
hidden link
thanks!

December 31, 2019 at 5:07 pm #5216651

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Thank you for that.

I am doing a test but I need your help.

I have created a new new template and translated it here: "CTA box – haut – Wpml", "CTA box – haut – Wpml en",

But I don´t know how to make it a "Global widget".

Could you please do this and then include the widget in a page?
Thanks

December 31, 2019 at 5:23 pm #5216659

sandraW-3

Right click on the item, and then you can access them in the left panel.
Thanks!

December 31, 2019 at 5:30 pm #5216707

sandraW-3

Hmm. Read too quickly. You chose a different route. It is actually registered as a global widget and should therefore be accessible in the panel.

December 31, 2019 at 8:30 pm #5217107

sandraW-3

Hey, I see that you have been working on the plugins installed on the site. This is fine. Yet, it is helpful to discuss the plugins you install and those that you deactivate. Thanks and happy new year!

January 2, 2020 at 11:33 am #5222893

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

OK regarding the plugins.

I do not see the widget as selectable from the Elementor editor panel. (see image)

So, there is something that is missing in how it is defined as "global".a The listing should say that it is a type = "Global widget" and not "page"

January 2, 2020 at 12:08 pm #5223205

sandraW-3

Hi again,

Yes, you are right. There are two elements - it's confusing :
- global blocks = a full section like you created one
- global widgets = my CTA, see hidden link
This is why you can't see yours in the left menu.

I hope that helps. And thanks again.

January 2, 2020 at 12:35 pm #5223489

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hmmm. Ok

Could you please create a new global widget in French with just a text block that is centered (similar to your CTA- haut).

Do not translate this widget. It should be a "Global widget".

The write back so that I can translate it myself for testing and validation purposes.

Thank you for your assistance.

January 2, 2020 at 1:52 pm #5223957

sandraW-3

Here you are: hidden link ( I put a grayish background) .

It's the WPML test F.

Thanks