Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.64 hours from now. Thank you for your understanding.

This topic contains 3 replies, has 2 voices.

Last updated by Riffaz 2 months, 2 weeks ago.

Assigned support staff: Riffaz.

Author Posts
March 24, 2021 at 10:04 pm #8394241

seanC-13

I am trying to: View a page in Italian

Link to a page where the issue can be seen: hidden link

I expected to see: The main menu in English

Instead, I got: The main menu changed into the language menu

Screenshot 2021-03-24 at 22.03.29.png
March 25, 2021 at 2:22 am #8394781

Riffaz

Hi,

Thank you for contacting WPML support.

Did you translate your menu as explained here? https://wpml.org/documentation/getting-started-guide/translating-menus/
Please translate the menu as explained there and check the issue.

Let me know the results after checking this please.

Regards,
Riffaz.

March 28, 2021 at 11:47 am #8416855

seanC-13

Hello Riffaz

Thank you for your email.

I did the menu sync, but what I found is, only the pages that have been translated appear in the menu. I would only like the foreign language flags to appear if a translation exists for that page - otherwise, the standard English pages/menu should appear.

March 29, 2021 at 7:20 am #8419601

Riffaz

Hi,

I would only like the foreign language flags to appear if a translation exists for that page.
- Just use the 'skip language' option in WPML > Languages > Language switcher options : hidden link

Let me know the results after checking this please.

Regards,