This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 4.07 hours from now. Thank you for your understanding.

This topic contains 2 replies, has 2 voices.

Last updated by gregoryh-4 2 months, 2 weeks ago.

Assigned support staff: Noman.

Author Posts
July 31, 2019 at 7:13 am #4312059

gregoryh-4

I am trying to: display the menu in spanish!

Link to a page where the issue can be seen: hidden link

I expected to see: the menu in spanish

Instead, I got: nothing or in english

July 31, 2019 at 8:10 am #4312709

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

=== Please backup your database and website ===

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40MB as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '512M');
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

2. Could you please make sure you have followed our step by step guide for menu translation:
https://wpml.org/documentation/getting-started-guide/translating-menus/

3. If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Thank you

July 31, 2019 at 2:47 pm #4315463

gregoryh-4

My issue is resolved now. Thank you!