This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The main menu on my website is not fully synchronized with the menu of the secondary language. As a result, when I try to change the language the menu does not change and remains in its original language (not expected), the language of the page changes (expected), and the flag disappears (not expected). Secondary Menu was created manually instead of translating it.

Solution: The pages were set not to be translatable in WPML → Settings → Post Type Translation and this was making the language switcher point to the same language page.

This topic contains 8 replies, has 2 voices.

Last updated by Radu 1 month ago.

Assigned support staff: Radu.

Author Posts
September 13, 2019 at 7:13 pm #4570503

dimitriosV-3

The main menu on my website is not fully synchronized with the menu of the secondary language. As a result, when I try to change the language the menu does not change and remains in its original language (not expected), the language of the page changes (expected), and the flag disappears (not expected). Secondary Menu was created manually instead of translating it. In WPML - WP Menus Sync I see that the menus are not fully synchronized but I can't synchronize them manually as I have the simple WPML version.

September 16, 2019 at 5:48 am #4576391

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Dimitrios,

Thank you for reaching out the WPML support!

I checked the homepage of your website and tried to change the language. Everything worked fine since I was taken to this page hidden link where the language is changed and the menu items are different too. I also checked a different page like hidden link too and when I use the language switcher to change the language I go to hidden link which seems to be working as well.

Can you send me a link to a page where I can see the issue you described, please? Or maybe you managed to sort things out in the meantime.

Thanks,
Radu

September 16, 2019 at 6:22 am #4576521

dimitriosV-3

See for example the page hidden link when changes to Greek turns to hidden link instead of hidden link
Synchronization problems also occur to the Menu’s pages: Introduction, Members/board of directors, Members/Member Registration, and in all pages marked with blue colour in the uploaded photo from the WPML-sync

September 17, 2019 at 12:46 pm #4588521

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Dimitrios,

I have to admit that this is the first time I see this issue. It's really strange that the language switcher link is pointing to the same language (hidden linkhidden link). Could you tell me if this issue is still available if you deactivate all the plugins except for WPML, please? This might be an issue added by one of the plugins you're using, especially from the one for optimizing and cache. Please let me know how this goes.

Also, try to activate the parent theme (instead of using the child one) too.

Thanks,
Radu

September 17, 2019 at 5:40 pm #4590467

dimitriosV-3

Dear Radu,
I have followed your instructions and deactivated all the plugins except WPML, also I activated the parent theme (instead of the child one), but the problem remained.
In the next step, I deleted the WPML plugin and I installed
Sitepress-multilingual.cms.4.3.0-b.8.zip
The problem remains as before. The language of the page changes into Greek (expected), the menu remains in the same language English (not expected), the flag switcher disappears (not expected). The WPML does not synchronize the pages with the main menu.

September 18, 2019 at 9:50 am #4594545

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Dimitrios,

Thank you for testing this out. Now, I think I should have a closer look at the settings to figure it out why is this happening. In this case, could you give me access to the dashboard area so I can have a closer look at this, please?

The next reply is set to be private so you can safely send me the credentials.

Thanks,
Radu

September 18, 2019 at 5:18 pm #4599325

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Dimitrios,

Can you check again the Keisa page (hidden link) and tell me if things are working fine now, when you select the Greek version, please?

Thanks,
Radu

September 18, 2019 at 5:29 pm #4599337

dimitriosV-3

Dear Radu,
It seems that everything works fine now. Let me know what caused the problem to close the issue.
Thanks

September 20, 2019 at 11:31 am #4611719

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Dimitrios,

The pages were set not to be translatable (in Dashboard → WPML → Settings → Post Type Translation). Once I changed them back to be translatable, things went back to normal.

Regards,
Radu