This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: When changing the language, the My Sale Items and My Sales Report pages are not displaying the right content. The page in secondary language is blank. Solution: In order to have everything working fine, the languages in directories needs to be used. Also, the following arguments have to be added to the Preserve URL arguments field: selling_ads_report,sellsrch,selling_ads_report,srchdtfrm,srchdtto,adid,selling_ads. This way, the parameters needed by those two pages are kept and the content is displayed well.

This topic contains 16 replies, has 2 voices.

Last updated by hlaingM 4 months, 3 weeks ago.

Assigned support staff: Radu.

Author Posts
May 12, 2019 at 7:51 pm #3793671

hlaingM

I am trying to: see the identical page when the language switch is clicked

Link to a page where the issue can be seen: attached (slide 1 through 5 in order)

I expected to see: the same page when the language switch is clicked

Instead, I got: a page with blank

May 13, 2019 at 11:14 am #3797365

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Could you give me access to the dashboard area so I can have a look at this page and see why is it not looking well, please? The next reply is set to be private so you can safely send me the credentials.

Thanks,
Radu

May 13, 2019 at 12:00 pm #3797691

hlaingM

hi,

I do not see the place to type private information. Could you please re-set it to be private? Thank you.

May 13, 2019 at 12:11 pm #3797871

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Can you give it another try, please? I set again the next reply to be private.

Thanks,
Radu

May 14, 2019 at 1:15 pm #3807163

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Can you check this page now and tell me how it works, please? I could see that this button was adding a new argument to the URL hidden link; and when changing the language, this part was removed. Now everything should be working fine. Can you check this out, please?

Thanks,
Radu

May 14, 2019 at 3:54 pm #3808913

hlaingM

Hi,

There are contents in the sales report if you give a range (in the example attached, I set the range from April to May).

In the example shown, when the 2nd language switch is clicked, those item list disappears.

Similar issues exist with other items (for example, "my selling items") underneath the seller dashboard.

If you set the next message private, I can give you the password for the example shown below for (username: zingyixiu) so that you can see the list.

Thanks.

May 15, 2019 at 1:20 pm #3816881

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

I set the next reply to be private so you can send me the second account and see if there's anything we can do to keep the filter values while changing the language.

Thanks,
Radu

May 16, 2019 at 8:48 am #3823367

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Thank you for sharing this account with me. This way I was able to see what are the arguments used for the search query. I added these to preserve too and now everything should stay the same while changing the language. Can you have a look, please?

Thanks,
Radu

May 16, 2019 at 10:00 am #3824397

hlaingM

Hi,

Thank you for an update. I see the following issues upon checking.

(1) At "Seller Dashboard", switch to the 2nd language. Then, when click on the 2 translations, you DON'T get what you expect.

(2) At "Seller Dashboard", click on "My Sale Items" in English and you will see a list. When you switch to the 2nd language at this point, you DON'T get what you expect.

Thanks.

May 17, 2019 at 8:35 pm #3836857

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

1. I'm using the second account you send to me, I still cannot see any item on this page: hidden link. Is there any other page I should check on Seller Dashboard? If yes, please send me a link to it and I'll have a look.

2. Can you check My Sale Items page now? It should work fine now when changing the language.

Thanks,
Radu

May 20, 2019 at 8:21 pm #3850071

hlaingM

Hi,

I edited the username to "zingyixiu" and pw credentials in the May 15 private message. In "Sales Report", you have to click "search more" and give a range from at least April 1st to May.

Thanks.

May 21, 2019 at 12:30 pm #3855075

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

I used the zingyixiu account and checked this page: hidden link. Once I changed the language, the values for filtering remained and this is how it looks hidden link. I attached two screenshots from each language.

Can you tell me what did you expect to be different, please? Or, are things looking different on your side?

Thanks,
Radu

May 21, 2019 at 3:38 pm #3856869

hlaingM

Hi,

Please see the image attached. That is clearer at elucidating the issues.

Thanks.

May 22, 2019 at 7:56 am #3862707

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

It seems that the button from your screenshot is made to add ?selling_ads=1 while it should add &selling_ads=1 because there's already the language parameter available.

This is the link that works well: hidden link; and this is the one that's not (when trying to access the button from the secondary language, not by changing the language while already on that page): hidden link;?selling_ads=1. In this case, can you reach out the theme author and ask him to have a look at this, please? He needs to make a little change to the code to check if there's already a parameter added to the link or not. Also, another thing that you can try is go to Dashboard → WPML → Languages → Language URL format and change this option from Language name added as a parameter to Different languages in directories. This might fix the problem too.

Thanks,
Radu

May 22, 2019 at 9:38 pm #3869473

hlaingM

Hi,

Thank you for your response.

It has nothing to do with the theme. That (sales report) is the feature of the plugin (not the theme). Anyway, changing setting your provided here works. (1) What does that setting really do?

(2) Do I have to check the checkbox of "Use directory for default language" at the option "different languages in directories"?

Thanks.