This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 4 voices.

Last updated by Mihai Apetrei 8 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
February 12, 2019 at 5:24 am #3186635

anastasiaM

Cannot update because of that error

February 12, 2019 at 8:03 am #3187014

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

I am sorry for the inconvenience.

This is a known issue and we are working on a fix. For now, please use the workaround our colleague, Vincenzo, added in this ticket: https://wpml.org/forums/topic/error-when-trying-to-update/

From what I can see, it seems that Vincenzo also left you an answer there, on the ticket above.

Kind regards,
Mihai Apetrei

February 12, 2019 at 9:08 am #3187414

anastasiaM

The workaround does not work. Manual is not an option. I will go nuts if i do this in all sites

February 12, 2019 at 9:00 pm #3190900

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Can you please check the message in the yellow box at the top of this page and let me know if that solves your issue?

It's this one:

"Hi everyone! we have just released a new bugfix version please see here the issues that it resolves: https://wpml.org/2019/02/wpml-4-2-1-with-stability-improvements-and-bug-fixes/

If you have an issue updating, please follow these simple steps: https://wpml.org/de/forums/topic/update-failed-7/ - that issue is fixed but for some older versions it might be happening"

Please let me know.

Kind regards,
Mihai

February 13, 2019 at 4:27 am #3192088

anastasiaM

I do not have OLDER versions. I had the previous one. I have it on a lot of sites. It will take me a long time to manually update. I need this to work from managewp desktop.

February 13, 2019 at 5:15 pm #3195578

Amit
Supporter

Hi there,

My name is Amit, WPML support manager, we are thinking of a solution for this,

I'll keep you updated ASAP

February 13, 2019 at 6:54 pm #3195835

Adriano
Supporter

Hello Anastacia,

This is Adriano, WPML developer, I'm really sorry about this issue. I don't know much about ManageWP, however, after watching this video I had one idea: hidden link

- Make a backup of all your sites, so you can recover them quickly if needed
- On ManageWP panel click to select all sites
- Then deactivate WPML Multilingual CMS plugin for all sites
- And click the button to delete WPML Multilingual CMS plugin for all sites
- Download the latest version of WPML Multilingual CMS plugin from your wpml.org account
- Still, on ManageWP panel, click to add a new plugin and upload the downloaded file from wpml.org there
- Activate WPML Multilingual CMS
- After that, you will have the latest version of WPML Multilingual CMS running. Then you can update other WPML plugins (String Translation, Translation Management, etc)
- The only that needs a manual upgrade is WPML Multilingual CMS one

Please let me know how it goes.

February 18, 2019 at 8:43 am #3210544

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi Anastasia,

Can you please let me know if the steps recommended above by our colleague, Adriano, work for your current case?

Please let me know.

Kind regards,
Mihai