This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by vovaH 5 months ago.

Assigned support staff: Bigul.

Author Posts
April 22, 2019 at 1:35 pm #3656025

vovaH

My problem:

In the Translation Management, I see the following: A page in Italian has the status of "In Progress". But if you open the list of pages, then there is no status in it. Inside the page - also. (See screenshots)

Because of this, I cannot create a duplicate (a separate page is created that is not related to the original)

What I did before this problem arose: I deleted one row in the wp_icl_translate_job table just for this translation. Probably I need somewhere else to remove something, so that WPML thought that the translation really does not exist for this page.

But I do not know what exactly needs to be removed. Please help me solve this problem.

April 22, 2019 at 7:10 pm #3658007

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please add yourself as a Translation Manager from WPML>>Translation Management>>Translation Roles. Then visit WPML>>Translation Management>>Translation Jobs and check is there any translation job related to the *Contact* page.

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

--
Thanks!

Bigul

April 23, 2019 at 8:46 am #3660889

vovaH

I don't have any translation job related to the *Contact* page in the Translation Manager. Maybe, because I deleted this record from database (after which there was this problem)

April 23, 2019 at 1:32 pm #3664357

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Upgrade to the latest version of WPML(4.2.6)

2) Go to WPML>>Support page

3) Click on Troubleshooting link (blue link in the middle of the page)

4) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

--
Thanks!

Bigul

April 24, 2019 at 8:45 am #3670481

vovaH

I tried to do what you wrote.
1) In item "Assign translation status to duplicated content" I get an error

2) In the Translation Management, the problem record not disappeared

3) I still can not make a duplicate of this page. It's creating as a separate page in Italian and is not connected to the original in English.

3.1) I tried to create a new page and assign it as a translation for the "Contact Us" page. It also failed. When I want to select a page of the original - the list doesn't contain the page I need.

April 24, 2019 at 2:24 pm #3673959

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

April 29, 2019 at 5:04 pm #3705747

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. I have discussed this issue with our team. Most probably this is happening because each record in the *icl_translation_jobs* table has a bunch of child records in *icl_translate* table. And it is not recommended to delete the records directly from the table. It is may harm the site. So we would like to know the following to track the issue.

1) Do you have a backup before deleting this job

2) Please share with me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

April 30, 2019 at 1:40 pm #3711773

vovaH

1) I don't have backup 🙁
2) hidden link

Thanks!

April 30, 2019 at 6:07 pm #3714015

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates and Debug log. Debug log is showing few warnings related to WPML. It requires further checking. So please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

May 13, 2019 at 8:27 am #3796049

vovaH

My issue is resolved now. Thank you!