Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Yvette 3 years, 2 months ago.

Assigned support staff: Yvette.

Author Posts
May 15, 2017 at 11:41 am #1276033

mohamedl

I am trying to: translate woo commerce

URL of (my) website where problem appears: mallocco.com/sandbox

I expected to see: translated pages for woo commerce

Instead, I got: multilingual woo commerce created the missing pages, but none are working and i can't edit them, stuck on the wheel (as if the translation sins finished) and when i go to the language pages i can't edit the elements

Steps to duplicate the issue: activating plugin, clicked add missing pages

May 15, 2017 at 11:47 am #1276039

mohamedl

example

May 15, 2017 at 5:25 pm #1276480

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I will be helping you with this issue.

1. Min system requirements
Your technical information indicates you are still using the default WordPress value for PHP memory of 40M for your installation. The minimum required for WPML alone is 128M. With Woocommerce and all the additional plugins you have installed...I would increase this to the maximum that you can which seems to be 512M.

This will be done by editing the wp-config.php file at the root directory of your WordPress installation and adding the line:

define('WP_MEMORY_LIMIT', '512M');

You can read more about this here: https://wpml.org/home/minimum-requirements/

2.1 After increasing the memory size, then do the following:

2.1. Temporarily deactivate your non-WPML plugins except for Woocommerce.
2.2 Also, change your active theme to Twenty Fourteen.
2.3 Now, please visit Woocommerce -> System Status and address any warnings/configuraiton errors
2.4 Then visit Woocommerce -> Woocommerce Multilingual -> Status
Address any warnings/configuration errors.

In this state, are you able to see the shop page in both of your system languages?

If so, then please go and reactivate the non-WPML plugins and change your active theme back to "Mallocco Child".

Thanks.

May 15, 2017 at 9:30 pm #1276667

mohamedl

i dont know why the debug or even some plugins display that i have 40mo for php, the hosting compagny confirms i have already 512mo for each install, also on the php section i have the limit to 512

May 16, 2017 at 11:36 am #1277087

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Short answer: because you are confusing two different things.

Your PHP memory limit is different from the amount of this PHP memory allocated to WordPress. You are showing me the quantity of PHP memory...not what is configured for WordPress.

You control this amount in your wp-config.php. If not quantity is specified there, then the default of 40M is taken.

The minimum Wodpress Memory Limit for normal WPML is 128M. With all of the plugins and Woocommerce..I would recommend you use 512M (your PHP Max at the moment).

More here: https://wordpress.stackexchange.com/questions/131179/php-memory-limit-vs-wp-memory-limit

May 16, 2017 at 1:18 pm #1277233

mohamedl

i changed it, deleted the languages and added them again, but still just the loading sign and i can't edit any of them

May 16, 2017 at 1:28 pm #1277251

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Did you do this?

2.1. Temporarily deactivate your non-WPML plugins except for Woocommerce.
2.2 Also, change your active theme to Twenty Fourteen.
2.3 Now, please visit Woocommerce -> System Status and address any warnings/configuraiton errors
2.4 Then visit Woocommerce -> Woocommerce Multilingual -> Status
Address any warnings/configuration errors.

In this state, are you able to see the shop page in both of your system languages?

May 17, 2017 at 6:52 pm #1278539

mohamedl

i told you i already tried what you asked in the first message, and thanks to that i lost some personalization i did
and i have the same issue,

May 17, 2017 at 7:54 pm #1278591

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Ok. Normally, configuration options are stored in the database and are not deleted between activation/deactivation of themes/plugins. So I am sorry that you had to redo work!

1. Please ensure you have a restorable backup of your system

2. Temporary access to your system
I would like to check your configuration.
Could you please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem? The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

Thanks

May 18, 2017 at 11:31 am #1279113

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi there.

I can see that these pages were sent to an external translation service POEDIT. Until this translator sends back a notification to the system that the job has been completed, the status will remain "in progress".

Normally, these pages would not have to be sent to a translator since it only contains a shortcode.

Are you able to contact the POEDIT service to have them mark the job as completed? This will free up the pages for access.

KR.

May 19, 2017 at 10:31 am #1279987

mohamedl

tried canceling the translation but doesn't work

May 19, 2017 at 2:09 pm #1280293

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

No, the job would have to be resigned by the translator so that it can then be cancelled.

Are your working with this 3rd party translator?

I think we can delete the job or even unhook the pages and recreate the translations if needed.

Thanks for letting me know.

May 19, 2017 at 5:37 pm #1280511

mohamedl

working with it but not really using it now,
deactivate it, changed the api key, deleted the projects, but doesn't seem to have any effect.

May 22, 2017 at 11:42 am #1281513

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello.

To move you along on the project, it seemed to be easier to create a new shop page and cleanly translate it.

You can now view your shop pages in all languages. To facilitate this, I also duplicated one of your existing products and then "translated independently " to all languages.

I hope you can now move ahead with your sandbox testing. You can just delete the page called "Old Shop" now.