This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Riffaz 3 weeks, 4 days ago.

Assigned support staff: Riffaz.

Author Posts
September 22, 2019 at 11:35 am #4618283

Mike

I selected Chinese, English, and Japanese as languages with English as the default language but the site went automatically to Chinese and did not allow me to add English as a language. It's stuck in Chinese and English box cannot be checked.

September 22, 2019 at 12:08 pm #4618413

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

1. Go to WPML > Languages > Add/remove languages page, open the browser console and check the html of the English language checkbox and removed the "disabled=disabled" attribute. This hidden link should be like this: hidden link

2. The checkbox will be enabled. Check the checkbox and click Save.

3. English will now be added and set it as the default language.

how to inspect element: hidden link

If that doe not help, please let me know your site wpml debug info for better and faster support: https://wpml.org/faq/provide-debug-information-faster-support/
I am enabling the wpml debug info field for next reply.

Regards,
Riffaz.

September 22, 2019 at 12:55 pm #4618587

Mike

Thank you Riffaz, I checked in the browser console but the fix doesn't work. At this point would it make sense to remove all WPML plugins and start over? Kind regards, Mike

September 22, 2019 at 1:00 pm #4618623

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

If it is a fresh installation you can try from the scratch again.
Before that, disable all the third party plugins except WPML and check the issue.

Let me know how it goes.

Regards,

September 22, 2019 at 2:23 pm #4618729

Mike

Hi Riffaz,
All 3rd party plugins disabled, re-installed WPML but English language checkbox is still disabled. It's the only language checkbox that is not accessible so must be some bug, default is to Chinese. Any other ideas on how to fix greatly appreciated. Thanks for your help. - Mike

September 22, 2019 at 2:27 pm #4618733

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Let me know your site login details to check what we can do from our side.
The next reply is private.

Regards,

The topic ‘[Closed] The plugin does not allow me to select English as a language.’ is closed to new replies.