This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 2 replies, has 2 voices.

Last updated by pilarC-4 2 weeks, 6 days ago.

Assigned support staff: Bobby.

Author Posts
September 26, 2019 at 5:30 pm #4649329

pilarC-4

I am trying to: I want to have English and Spanish on my website so I purchased your plugin and installed it yesterday. I want to keep my main language domain, English as traveltheworldpages.com and the plugin has changed it to hidden link
It has changed also all my post URLs in English. Basically it has created a mess I did not want.
I am OK with the Spanish version and URLs being hidden link
but the main language, English I want it to be purely.com domain.

Can you please help me reverting all these changes?

Link to a page where the issue can be seen:hidden link

I expected to see: The same page under the original URL
hidden link

Instead, I got:

I cannot provide with debug information as when I go to the plugin that option is not available.

September 26, 2019 at 5:58 pm #4649461

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

Please go to WPML->Languages->Language URL format -> uncheck the option "Use directory for default language".

This will remove the directory from your default language.

Let me know your results, please.

September 26, 2019 at 6:08 pm #4649603

pilarC-4

My issue is resolved now. Thank you!