This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.86 hours from now. Thank you for your understanding.

This topic contains 17 replies, has 3 voices.

Last updated by Riffaz 3 weeks, 6 days ago.

Assigned support staff: Riffaz.

Author Posts
September 2, 2019 at 8:55 am #4495523

olgaV-2

I had problems installing WMPL because it broke my web. Now it seems to work. However, today i tried to install Woocommerce multilingual and it broke the place again

Thank you in advance

September 2, 2019 at 11:36 am #4496619

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML, Woocommerce and Woocommerce Multilingual and see if this issue goes away with default theme and only these plugins activated?

Thank you

September 5, 2019 at 4:05 pm #4520677

olgaV-2

It still breaks the site.

Fatal error: Uncaught InvalidArgumentException: element_id and type do not match for element_id:30 the database contains tax_category while this function was called with tax_product_cat in /home/lu39x45d/olgavillanueva.com/wp-content/plugins/sitepress-multilingual-cms_old/classes/core-abstract-classes/class-wpml-set-language.php:32 Stack trace: #0 /home/lu39x45d/olgavillanueva.com/wp-content/plugins/sitepress-multilingual-cms_old/sitepress.class.php(1484): WPML_Set_Language->set('30', 'tax_product_cat', false, 'es', NULL, true) #1 /home/lu39x45d/olgavillanueva.com/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-install.php(122): SitePress->set_element_language_details('30', 'tax_product_cat', false, 'es') #2 /home/lu39x45d/olgavillanueva.com/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-install.php(52): WCML_Install::set_language_information(Object(SitePress)) #3 /home/lu39x45d/olgavillanueva.com/wp-content/plugins/woocommerce-multilingual/classes/class-woocommerce-wpml.php(248): WCML_Install::init in /home/lu39x45d/olgavillanueva.com/wp-content/plugins/sitepress-multilingual-cms_old/classes/core-abstract-classes/class-wpml-set-language.php on line 32

September 8, 2019 at 7:05 am #4530677

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site, so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

September 9, 2019 at 11:31 am #4536671

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Noman is off for few days and I will be helping you on this. 🙂

Thank you for your new site details.

May I know, has this happened after the WCML installed? or this happened even before you installed the WCML?

Let me know.
Regards,

September 9, 2019 at 3:15 pm #4538485

olgaV-2

Riffaz,
It is a pitty you don't keep historical, because it has been a night mare installing the plugin from the very begining.
First I installed
WPML Multilingual CMS
WPML String Translation
WPML Translation Management

and the web was broken too when activating CMS.

Now I am having problems with WooCommerce Multilingual

Thank you and regards

Olga

September 10, 2019 at 11:53 am #4545009

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the details.

I logged in and checked your site.

1)
You have latest version only in WPML Multilingual plugin: hidden link
Could you please update other WPML plugins first then I can process to fix the issue mentioned?

2)
I do not see any error notification in your site.
Are you getting the error you mentioned here https://wpml.org/forums/topic/the-pluging-wpml-multilingual-cms-breaks-my-site-3/#post-4520677 only if you enable the WCML?
How to check your issue?
What are steps to produce it?

Let me know, please.

Regards,

September 11, 2019 at 12:59 pm #4553535

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the details.

I am unable to check your database using the classic way..
I think your root is different..

Could you please give me a way to access to the site database?
cPanel or any other way?

Let me know.

Regards,

September 12, 2019 at 8:01 am #4559133

olgaV-2

Well, I have many clients there and I would rather if there is any other way...
I do not think the plugins or the theme I am using are that odd...
Is there other way for you to check?
Thank you

September 12, 2019 at 2:15 pm #4561635

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Please follow these steps then:

1. take a backup of your database
2. run this query:

 DELETE FROM wp_icl_translations WHERE element_id = 30 AND element_type LIKE "tax%"

3. then run "Set Language Information" in WPML > troubleshooting

let me know how it goes.

Regards,

September 16, 2019 at 5:40 am #4576381

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I do not think the details you provided for hidden link because I do not see your site in it's control panel: hidden link

Please ask your hosting support how to login to this? hidden link
They will let you know the correct credentials for this.
Then let us know.
The next reply private.

Regards,

September 18, 2019 at 5:18 am #4592503

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the details.

It's delaying because we are unable to find a way to access to your database.
I spent half an hour on your control panel but I could not see any link or button to check uyour database.
your hosting control panel is really strange.

Could you please simply ask your hosting support how to login to "hidden link" or how to access to the database of hidden link?

Then let us know the steps.

Regards,

September 19, 2019 at 12:47 pm #4604843

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Ok, this is something our second tier should check.
I am assigning this to one of our second tier support.
Please be patient till he gets back to you again.

Regards,

September 19, 2019 at 12:51 pm #4604857

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Sorry, ignore my previous reply.

September 19, 2019 at 1:05 pm #4604987

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the details.

This is done.
Please check your site.
It should work fine now.

Let me know if you need anything else regarding this.

Regards,
Riffaz.