This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Bobby 2 months, 3 weeks ago.

Assigned support staff: Bobby.

Author Posts
July 22, 2019 at 5:26 pm #4260425

julizarS

Tell us what you are trying to do? trying to get help from video

Is there any documentation that you are following? no

Is there a similar example that we can see? open the admin

What is the link to your site? hidden link

Hallo.. I think something wrong with my website, since I activated wpml, I cant translate the string properly.

I have install this plugins:
WPML CMS Nav, WPML Media, WPML Multilingual CMS, WPML Sticky Links,
WPML String Translation, WPML Translation Management

But the wpml menu on admin bar only this: hidden link
and the admin page also empty like this: hidden link

Thanks for your help

July 22, 2019 at 10:51 pm #4261655

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

please click on the button to "Learn More" , then you should be able to "x" out the message and get the white background removed.

please let me know your results afterwards.

also are you still not able to see the option "Languages" within the WPML menu ?

if yes please review your permissions and verify that you can write and save in the database

July 23, 2019 at 12:08 pm #4265843

julizarS

Hi..

Not language option but menu on admin bar.

See this video screen, this is wpml on my other website mahkotaproperty.com : hidden link. There are lots of menu available

Then compare with this this one is the screen shot menu on my website julizar.com: hidden link ini this website there are lots of missing menu.

I have aslo translate some string on string translation but no changing on front end: see the screen shot: hidden link

Other thing I normally can sent you debug information from support menu, but in here there is no debug menu, so that I cant sent you the debug information.

Thanks

Please help.

July 23, 2019 at 7:22 pm #4268739

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

This can happen due to missing certain permissions

Were you able to verify your permissions ? Are you able to write ,edit and delete in the database ?

Please take a backup of your site first and then if possible I suggest you run the following snippet:

function wpmlsupp_1706_reset_wpml_capabilities() {
if ( function_exists( 'icl_enable_capabilities' ) ) {
icl_enable_capabilities();
}
}
add_action( 'shutdown', 'wpmlsupp_1706_reset_wpml_capabilities' );
Just add the above code in your theme's functions.php file (between the <!--?php and ?--> tags) and visit once the front-page.
Then you can remove this snippet.

Please let me know if this fixes the issue.

If it does not i have enabled the private field reply for you to share your access details with me

July 24, 2019 at 7:42 pm #4277217

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

i took a closer look and can confirm that the script i provided has resolved the issue of the plugin options not showing within the menu which was caused by the permissions on the site.

As we try to keep each ticket to 1 issue please open a new ticket on the support forum regarding the translation issue as this is a separate issue.

Kind Regards,
Bobby