This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 3 voices.

Last updated by Jamal 1 month, 1 week ago.

Assigned support staff: Jamal.

Author Posts
August 23, 2019 at 9:21 pm

vitoP-2

I am trying to: update the portfolio

Link to a page where the issue can be seen: hidden link

I expected to see: the translated item hidden link

Instead, I got: nothing

August 24, 2019 at 2:06 am
August 31, 2019 at 4:57 am
September 1, 2019 at 8:54 am #4492229

vitoP-2

Hi

as I said the page looks completed but it doesn't show on production

I provided the access details for you to evaluate what is wrong

thanks

September 4, 2019 at 3:27 pm #4512515

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Our apologies for the late reply. Rajeeb was not available this week, and we missed the tickets assigned to him.

I checked the pages of your portfolio in both languages and they seem working both, they both show several portfolio items:
- hidden link
- hidden link

I have also visited some portfolio items pages and they show up correctly, as an example:
- hidden link
- hidden link

Can you please elaborate a little more on your question so I can better understand?
Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit, so if you like, make use of “upload an image” below the comment area.

Looking forward to your reply.

Best regards,
Jamal

September 6, 2019 at 11:53 am #4525117

vitoP-2

Hi

the issue is on the latest post I did.

You see them in italian but they don't show in english.

I.E. hidden link

thanks

September 9, 2019 at 9:55 am #4535699

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi,

The portfolio translation was actually a draft. After I published it, it was visible on the English projects page. See the attached image.

Can you confirm from your side that the issue is resolved? Let me know if there is anything else I can do.

Best regards,
Jamal

September 12, 2019 at 6:55 am #4558675

vitoP-2

Hi

so in this case I would appreciate if you could tell me where is the publishing option

Regards

September 12, 2019 at 10:08 am #4559985

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Sure. It is the default WordPress status. As you can see in the attached image, you can edit the status of a portfolio item(or any custom post type) in the "Publish" Metabox provided by WordPress.

It is also worth to mention that WPML can keep status sync between the original post and its translation If you enable this setting in "WPML->Settings->Translated documents options->Document status", but this setting will only work when using Translation Editors. When translating manually, you will need to publish the translation manually too(Use "Publish" button instead of "Save" in the same metabox).

Best regards,
Jamal

September 12, 2019 at 11:52 am #4560699

vitoP-2

Hi

the problem is if I go into WPML translation it says it is 100% translated, but in the front end doesn't show

By going inside the portfolio item it only shows the italian version, and it says it is published

So my question is: where I decide to publish the english version?

thanks

September 12, 2019 at 1:37 pm #4561261

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi,

To publish the portfolio translation, open it in the native WordPress editor. See the attached image for the portfolio io e il mio cane - Consultancy
URL is hidden link

You can open this URL, by going to Portfolio->Protfolio, then switching to English Before the table or from the top bar language switched.
Then locate the portfolio item and hover over it to see the menu, click on edit. See the attached images

However, we should also resolve the issue "WPML translation it says it is 100% translated, but in the front end doesn't show". Would you like to work on that?

Best regards,
Jamal