This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Radu 3 months ago.

Assigned support staff: Radu.

Author Posts
July 10, 2019 at 6:39 am #4176347

raffaelep-8

I have a problem with posts, which even if they were created by selecting the Spanish language are published on the English page (see the link for the first 3 posts in Spanish).
The categories I selected are in Spanish but the result is as if I had selected categories in English. Could you please help me

hidden link

July 10, 2019 at 8:44 am #4177365

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

I just had a look at both Spanish and English pages and I could see that the content of the post is different. The only thing that remains the same is the title which is in Spanish, no matter what language you check. Is this the issue that we are talking about? I just want to make sure that I understand what is the issue so I can look for what might be causing it.

Thanks,
Radu

July 10, 2019 at 9:50 am #4177889

raffaelep-8

The problem that for the moment I should solve as soon as possible, is that practically in the "Expertise gs" page in English there are 3 posts in Spanish and I can't understand why ...

hidden link

July 11, 2019 at 8:50 am #4187625

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Can you go to Dashboard → WPML → Settings → Post Type Translation and make sure that the option selected for the Posts is Translatable - only show translated items (first column), please? The issue you have might be caused by the use of the Translatable - use translation if available or fallback to default language option. If the right option is already set here and the issue is still available, please give me access to the dashboard area and I'll have a closer look at this. The next reply is set to be private so you can safely send me the credentials.

Thanks,
Radu

July 12, 2019 at 7:26 am #4195959

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

You are definitely not disturbing me, so don't worry about that 🙂

The page that I was mentioning is this one: hidden link. As I can see, the option selected for the Posts (on the Traducción de tipos de entrada section) is the second column. In this case, when a translation is not available for a post, the original version is displayed. Since the three posts didn't had a English translation, the Spanish version was displayed instead. If you'll select the first column and save the changes, you'll see that the posts from Spanish will no longer be displayed in English.

Thanks,
Radu

The topic ‘[Closed] The problem with language post’ is closed to new replies.