This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by Andreas W. 7 months ago.

Assigned support staff: Andreas W..

Author Posts
March 7, 2019 at 3:43 pm #3285405

thomasM-76

Okay, I translated (at the moment I just copied the categories) to two new languages.

- In [WooCommerce Multilingual] they are all marked as translated
- In [WooCommerce Product Categories] they show up just like clones of the default language
- taxonomy hierarchy ia already synched

Still not showing up in the added languages, what am I missing ?

March 7, 2019 at 7:04 pm #3286513

thomasM-76

Okay I think I found the problem, but I am asking myself if this is really the way to.

Do I have to duplicate the products for translation? This is kinda insane, how do the stock values behave then, do I have to change 3x data if I have 3 languages?
Say I want to change the price then I have to do this for all languages?
Where do I choose the category now? It is gone from the products editor :-/

March 8, 2019 at 12:38 am #3288146

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

Thank you for contacting WPML Support.

It is not necessary to duplicate products. Usually you will only need WooCommerce Multilingual to keep your products available for each language and those translations are in fact the same product and not any copies or duplicates. As you metnioend this would cause issues regarding stock and prices.

Could you please go to WooCommerce -> WooCommerce Multilingual -> Status -> Troubleshooting (right bottom corner).
Here you will find many options for synchronizing your store content. There is also one option to sync product categories.

Could you please also confirm if the StoreURL for product categories is translated properly? You will find it on the WooCommerce Multilingual StoreURLs tab.

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us:
http://wpml.org/faq/provide-debug-information-faster-support/

Please let me know if you need any further assistance.

Kind regards
Andreas

March 8, 2019 at 6:54 am #3289588

thomasM-76

Hello Andreas,

ok followed the troubleshooting but it wasn´t solving the problem. All positions are on "0 remaining" now but the categories are still invisible and there still is no option to choose a category in the product - edit. I wonder where I have to set these now.

thanks!

Thomas

March 8, 2019 at 6:06 pm #3294856

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

March 9, 2019 at 9:25 am #3297590

thomasM-76

I´d feel better creating a duplicated version for you with the Duplicator plugin. Would that work for you?

March 9, 2019 at 11:17 am #3297862

thomasM-76

Okay I created a minimized clone without personal customer data, credentials and images with Duplication, however currently I cannot post in private mode here so I can´t send the link.

March 11, 2019 at 5:01 pm #3314909

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

You next reply is set to private by default. Please provide the package for further debugging.

Thank you!

Kind regards
Andreas

March 12, 2019 at 7:07 pm #3327637

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have now installed your website on my local environment and I enabled the WP-Debug feature.
https://codex.wordpress.org/WP_DEBUG

I would kindly like to ask you to preceed with the same on your live website.

I encounted various errors that are related to outdated versions of WooCommerce. Please update WooCommerce and any additional plugin to the latest version. Anyhow, this issue seems not to be related to WPML.

I further received some errors in regards to your WordPress Core. Did you process any custom coding on any of the files of your WordPress Installation?

You can find the debug.log file here:
hidden link

Kind regards,
Andreas

March 13, 2019 at 7:10 am #3330183

thomasM-76

Well, that messed up everything now. Bunch of php errors now. I am not quite sure if I messed with the core, been to long already since I started this but I did some mods with filters. Guess I killed them now, need to get them back from the clone. The versions of the plugins don´t have a relation to the problem though.

Well, this is a typical case of "never change a working system". Due to massive changes in the wordpress/woocommerce core the custom product plugin doesn´t work anymore so I need to fix this now, meanwhile it probably doesn´t make much sense to think about the category problem 🙁

March 13, 2019 at 10:36 am #3332105

thomasM-76

Okay I fixed all my issues with my custom plugin, kicked out the menu on footer plugin (for now) since there is no new version and disabled the category identifier "hack" in theme-customizations plugin, this one was made by me to allow direct to cart operations on non-custom products but since it caused a notice now I removed it for the moment.
HOWEVER all of it didn´t affect ´the category multilangual problem, so this is caused somewhere else 🙁

March 14, 2019 at 9:10 pm #3348511

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I can offer you to provide an updated Duplicator package and I will have a look at your websie again.

Anyhow,please take not that if the issue is somehow related to a custom theme or plugin then our support policy does not cover any help.
https://wpml.org/purchase/support-policy/

In such cases we refer to contact one of our contractors, who are all experienced developer with WPML knowledge.
https://wpml.org/contractors/

Your next reply is set to private in order to provide an updated Duplicator package.

Kind regards
Andreas

March 18, 2019 at 7:50 am #3366495

thomasM-76

Don´t know if the last private message was sent, however link is the same as the first duplicator file. Problem remains the same even if all plugins are disabled. My next guess would be to do a clean reinstall of wordpress / woocommerce but I am not sure how good a db backup / insert of my data would work then.

March 18, 2019 at 4:30 pm #3371563

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

If the issue persists as long WPML and even other plugins are disabled it means that the issue is related to the theme or even to WordPress Core.

Please try to change to a default theme like TwentySeventeen. If the issue persists it must be caused by the WP install. In this case I would advise you to reinstall WordPress or contact the WordPress Support.
hidden link

You might use this plugin to obtain a copy of your DB and update WordPress to Version 5.1.1 at Dashboard -> Updates. Hopefully this will solve the issue.

Kind regards
Andreas

March 18, 2019 at 4:58 pm #3371707

thomasM-76

No, WPML is -of course- enabled, the problem wasn´t there before. How could it, there are no other languages without WPML and in the default language the categories do work. The theme is storefront - it is a shop, no other theme was used so it started with the default theme. We are kinda running in circles now. Back to the initial post:

- Categories don´t work on additional languages, no categories selectable in product edit since WPML was installed.

- Even if all plugins (except those required for woocommerce and WMPL) are disabled the categories still don´t work, the wp core and woocommerce are updated to the latest version, this means if there were any mods (I don´t think I made even one to the core.) they are gone anyway. The modding plugin I used for customization is disabled and with that all filters.

- The themes are default ones, however even if not that wouldn´t explain why the product categories are not selectable in product edit/backend and the default language wouldn´t work either. I don´t believe in an error in the theme(s).

I am going to set up a parallel wordpress/woocommerce with WMPL and try to port my data somehow.

The topic ‘[Closed] The product categories don´t show up in translations’ is closed to new replies.