Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:We detected that the product_type field was set incorrectly for some product translations. This happened because the product_type taxonomy was translated. You can fix this in the WooCommerce Multilingual troubleshooting page

Solution:use FTP to go to your theme, then find the wpml-config.xml file and edit it.

You will need to find

product_type

once you do please remove that and save.

Once you go back to your dashboard you will need to clear your browsers cache and the notification will be removed. (check with incognito window)

Relevant Documentation:

0% of people find this useful.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 3 voices.

Last updated by Philippe 4 years, 11 months ago.

Assigned support staff: Bobby.

Author Posts
December 16, 2016 at 2:53 pm #1162354

Philippe

Hello,

Since the update of WooCommerce Multilingual 4.0.2, I see this message on the top of the screen:

«We detected that the product_type field was set incorrectly for some product translations. This happened because the product_type taxonomy was translated. You can fix this in the WooCommerce Multilingual troubleshooting page.»

I did updated all the sync of variables products in the Troubleshooting section, and I also did use the «Fix product_type taxonomy terms», but the trouble remain.

I don't understand what it means and how to fix it, so I need your help. Thank you!

woocommerce_multilingual.png
December 16, 2016 at 11:44 pm #1162709

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Thank you for contacting WPML Support,

The dashboard notice is related to this errata page: https://wpml.org/errata/product-variations-not-display-variation-original-language/
In WooCommerce Multilingual 4.0.2 we added the message and a button that fixes the problem if it is detected.
For PHP 5.4 I see now that we have a compatibility problem with that code and that is why there is a fatal error.
Usually WooCommerce Multilingual requires PHP 5.6 as noted here: https://wordpress.org/plugins/woocommerce-multilingual/installation/

If you don't have the fatal error - it is recommended to follow the instructions and fix the detected problem by following the link to the troubleshooting page and using the appropriate button.
You also can fix the problem with the fix provided in the errata page that I mentioned above.

=> =>Please do note - our developers just released a new version of WooCommerce Multilingual with number 4.0.3.
That version explicitly fixes the fatal error that is happening on the troubleshooting page.

Please update.

Please remember to backup your database and files first before you proceed! You can use a plugin for this if you like (example: http://wordpress.org/plugins/duplicator/)

December 17, 2016 at 3:32 am #1162749

Philippe

Hello Bobby,

Thank you for your fast answer. But I still need help. My current PHP version is 5.6, and I already use WooCommerce Multilingual 4.0.3. I did follow the instructions provided in the errata page, but it doesn't help. Now the message is:

«We detected a problem in your WPML configuration: the product_type taxonomy is set as translatable and this would cause problems with translated products. You can fix this in the Multilingual Content Setup page.»

I would appreciate if I could give you the credentials so you can take a look directly on my website.

Thank you!

woocommerce_multilingual 2.png
PHP-version.png
December 18, 2016 at 6:12 pm #1163094

Cinar

Hi,
I have exactly the same problem.. php :5.6 but getting that message since the last update..

December 19, 2016 at 6:59 pm #1164086

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

@Cinar please update to 4.0.3 if you have that version already then please open a new ticket on the forum and we will try to resolve your issue.

@Jovelyne
**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

December 21, 2016 at 1:50 am #1165252

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi,

Thank you for the Access details but i currently cannot access as either the Username or Pass is wrong

Also if you check your console erros on the front end you will notice
Uncaught SyntaxError: Unexpected token <
in your Chrome developer's console tab is often an indication of 301 Redirects that could be caused by having a strange rule in your .htaccess file. (causes the load issue)

What you're actually seeing is your browser's reaction to the unexpected top line <!DOCTYPE html> from the server.

December 21, 2016 at 2:31 am #1165255

Philippe

Hello Bobby,

Sorry for the mistake, it's my fault. You can try again to login again now.

December 21, 2016 at 7:57 pm #1166062

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi Im still not able to login

I have enabled the private field again

Thank you,
Bobby

Screen Shot 2016-12-21 at 11.55.54 AM.png
December 21, 2016 at 8:04 pm #1166071

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

P.S if it's connected with variations, please try to delete variations and create them from scratch

December 21, 2016 at 9:02 pm #1166117

Philippe

Hello again Bobby,

I just want to let you know that I have completely unactivated all WPML plugins to allow my co-workers to continue to work on the website (we expect to publish it for January 1st). You can re-activate all these plugins as soon as you will be loged in so you can see and solve the problem. Thank you very much!

December 22, 2016 at 1:25 am #1166207

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Thank you for letting me know !

If possible please try to delete variations and create them from scratch, this should resolve this issue

December 22, 2016 at 10:28 pm #1167064

Philippe

Hello Bobby,

For me, deleting all variations and creating them from scratch is really my last option, considering the time it reprensents. It is far more easy to remove WPML and re-install it from scratch. So it is what I did today. I have removed all WPML plugins (including Woocommerce Multilingual) and I have cleaned and sweeped the database (with plugins) to remove any traces. Then I have worked on my website all the day to test it without WPML. Tonight, I have re-installed from scratch WMPL and, surprise!, I have realized that all my translated strings did come back, and also the bug with product_type field. So my database was not completely cleaned.

So, my question is now: Do you think that I can bypass this bug by deleting and installing WPML from scratch? If so, could you tell me how to completely clean my website and database from all traces, to be sure to have a clean and functionnal re-installation?

Otherwise, I will try to delete variations and create them from scratch, but it really sucks...

Thank you!

December 22, 2016 at 11:41 pm #1167087

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi,

I have tried running the troubleshooting actions and i can see whats going on.

For the moment deleting WPML will not help, if you ever want to start from scratch you will need to reset WPML by going to WPML->Troubleshoot->and RESET WPML.

This would delete all translations and WPML content, allowing you to start from scratch.

I would like to troubleshoot the issue a bit more by getting a duplicator package and escalating it, i currently cannot access your site.

December 23, 2016 at 12:30 am #1167103

Philippe

Hi,
Indeed, our server was down for 13 minutes, and I guess you have tried to login during this period. Site is now back up, so you can try again. By the time, I will install Duplicator for you to save you some time. Thanks a lot!

December 23, 2016 at 2:34 am #1167117

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi ,

Please use FTP to go to your theme, then find the wpml-config.xml file and edit it.

You will need to find

<taxonomy translate="1">product_type</taxonomy>

once you do please remove that and save.

Once you go back to your dashboard you will need to clear your browsers cache and the notification will be removed. (check with incognito window)

I would do this for you but i dont currently have FTP access.
Test on local install with duplicator and everything is fine.