This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by romainL-11 3 weeks ago.

Assigned support staff: Lauren.

Author Posts
September 19, 2019 at 1:14 pm #4605089

romainL-11

I am trying to:
Link this french page :
hidden link?
With this translation in english:
hidden link

Link to a page where the issue can be seen:

I expected to see :
English to french when you click on flag but no
French to english is working fine

Instead, I got:
English to English
French to English

September 19, 2019 at 1:20 pm #4605131

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Please make sure that you have fully translated this page in French. Also, do you by any chance have French set to hidden language? On the page edit screen, do you see that the English and French pages are connected?

September 19, 2019 at 1:39 pm #4605439

romainL-11

Yes it is fully translated
Both pages are connected yes I have tried to delete the connection and connect it again also and get same result

"Also, do you by any chance have French set to hidden language"
I don't understand

September 19, 2019 at 2:34 pm #4606393

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

September 19, 2019 at 3:33 pm #4606907

romainL-11

Can you ask again please, and I need an email to give you an access

September 19, 2019 at 4:22 pm #4607327

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Sure, you can use lauren.j @ onthegosystems.com (without the spaces, of course).

September 19, 2019 at 6:03 pm #4607805

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

This issue was due to a redirect that was set up in Tools -> Redirection. I disabled the redirect and now the French page loads properly. I have attached a screenshot of the redirect that I disabled.

Please let me know if you need any further assistance and I will be happy to help.

September 22, 2019 at 7:51 pm #4619367

romainL-11

My issue is resolved now. Thank you!