This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 3 replies, has 2 voices.

Last updated by lawrenceS-3 3 months, 1 week ago.

Assigned support staff: Rohan Sadanandan.

Author Posts
July 15, 2019 at 12:52 pm

lawrenceS-3

I am trying to: Make the search result page multilingual

Link to a page where the issue can be seen: hidden link

I expected to see: Upon searching something, the search result page is showing only in English. If I select Chinese, the page, the page reloads and redirects to Home Page.

Instead, I got:

July 15, 2019 at 2:10 pm #4212019

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for contacting WPML Support.

If you wish to keep the URL arguments when switching languages, try the following steps:

- Go to WPML -> Languages
- Scroll down to the "Language switcher options" section
- Click on "Preserve URL arguments"
- Add the required arguments in the text field. eg. s,post_type
- Click outside of the text field to save.

Based on your search url, I've now added the below given arguments to your site:

search_keywords,selected_category,selected_jobtype,selected_location,selected_job_level

I hope your issue is resolved now.

If you need to add more arguments you can update as mentioned above.

You can read more in this documentation: https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/#preserving-url-parameters

Thanks,
Rohan

July 15, 2019 at 3:53 pm #4213117

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Updating the ticket status.

Thanks,
Rohan

July 16, 2019 at 1:15 pm #4220335

lawrenceS-3

My issue is resolved now. Thank you!