This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 3 voices.

Last updated by vorakarnw 2 weeks, 5 days ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
September 23, 2019 at 1:12 pm #4624339

vorakarnw

Hi Support,

Today I just notice that I am unable to access the translation both in advance mode or classic mode. The icon of each languages show all pencil which is not normal.

When I click on the pencil to edit the translation then it show "The site is experiencing technical difficulties Please check your site admin email inbox for instructions.

Please help

September 23, 2019 at 6:03 pm #4626049

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @vorakarnw, welcome to the WPML support Forum!

Please enable WP_Debug, WP_Debug_log and WP_Debug_Display on your website, it should display more details about the error: https://wpml.org/documentation/support/debugging-wpml/ - e.g.

define('WP_DEBUG', true);
define('WP_DEBUG_LOG', true);
define('WP_DEBUG_DISPLAY', true);

After that please reproduce the issue again then send us a screenshot of the error message.

All the best,
Diego

September 24, 2019 at 1:18 am #4626977

vorakarnw

Hi Diego,

Thank you for your support.

I have enable WP debug already but the error message still same "The site is experiencing technical difficulties. Please check your site admin email inbox for instructions."

Please see attached file.

Best regards,
Boyd

September 24, 2019 at 1:55 am #4627023

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Have you made those changes on the wp-config.php file? Can you go to wp-content folder and see if there is a debug.log file? If yes, can you paste the file contents here.

Also, are there any emails that are being sent in your email regarding this issue.

Look forward to your reply.

Thanks

September 24, 2019 at 2:12 am #4627125

vorakarnw

Hi

Please see below link for the log file

hidden link

i have received mail yesterday as attached image

Best regards,
Boyd

September 24, 2019 at 2:19 am #4627219

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for the details.

Could you please go to WPML-> Support ->Troubleshooting and click the below buttons:

+ Clear Cache in WPML
+ Set Language information
+ Fix element types collation
+ Remove ghost entries from the translation tables
+ Assign translation status to duplicated content
+ Set language information

Let me know if this helps.

Thanks

September 24, 2019 at 5:43 am #4628109

vorakarnw

Hi Shekher,

I did all your suggestion but still showing the same thing.

Please kindly advise.

Best regards,
Boyd

September 24, 2019 at 6:56 am #4628363

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

To debug this issue further, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

September 24, 2019 at 8:02 am #4628805

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

If we go to WPML->Languages and check the domains, one of the domains says not-valid, can you check if the domains are configured properly?

Also, I tried to check the ip using ping and I can see it's all pointing to different places so can you check if all the domains points at the same place?

To test, can you try to use a different url format and see if the problem exists?

Look forward to your reply.

Thanks

September 24, 2019 at 9:02 am #4629333

vorakarnw

our name server point to cloudflare and I try using hidden link to access this page I also found the same problem as screenshort

September 24, 2019 at 9:06 am #4629385

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Can you try to disable Cloudfare for a moment and see if that helps? also, can you try to use a different url format and see if the problem exists?

Look forward to your reply.

Thanks

September 24, 2019 at 9:13 am #4629495

vorakarnw

Hi Shekhar,

Both were not help.

Best regards,
Boyd

September 24, 2019 at 9:22 am #4629625

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I enabled the debug.log now, it looks like you paste the define('wp_debug, 'true'); in the bottom of wp-config.php file as a reason it wasn't working, I placed it above the /* That's all, stop editing! Happy publishing. */ and now I can see the errors.

I can now see that you are missing tables on your site which is creating this issue, so could you please use the solution provided in the following errata and let me know if this helps?

https://wpml.org/errata/missing-_icl_strings-_icl_string_translations-data-tables/

Look forward to your reply.

Thanks

September 24, 2019 at 11:35 am #4631167

vorakarnw

Hi,

I can not enter my site after activate this function.

Please see attached file

Best regards,
Boyd

September 24, 2019 at 12:01 pm #4631405

vorakarnw

FYI Please help