Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Puntorosso 2 months, 3 weeks ago.

Assigned support staff: Alejandro.

Author Posts
September 10, 2019 at 7:13 pm #4548445

Puntorosso

Hi, when trying to save a Formidable Pro View, I get this error

The site is experiencing technical difficulties. Please check your site admin email inbox for instructions.

In the email I get these error details

Error Details
=============
An error of type E_ERROR was caused in line 130 of the file /home/legendsv/public_html/cms/wp-content/plugins/wpml-media-translation/classes/media-translation/class-wpml-media-post-images-translation.php. Error message: Uncaught TypeError: Argument 1 passed to WPML_Media_Post_Images_Translation::translate_images_in_post_content() must be an instance of WP_Post, null given, called in /home/legendsv/public_html/cms/wp-content/plugins/wpml-media-translation/classes/media-translation/class-wpml-media-post-images-translation.php on line 107 and defined in /home/legendsv/public_html/cms/wp-content/plugins/wpml-media-translation/classes/media-translation/class-wpml-media-post-images-translation.php:130
Stack trace:
#0 /home/legendsv/public_html/cms/wp-content/plugins/wpml-media-translation/classes/media-translation/class-wpml-media-post-images-translation.php(107): WPML_Media_Post_Images_Translation->translate_images_in_post_content(NULL, Object(WPML_Post_Element))
#1 /home/legendsv/public_html/cms/wp-includes/class-wp-hook.php(288): WPML_Media_Post_Images_Translation->translate_images(4075)
#2 /home/legendsv/public_html/cms/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
#3 /home/legendsv/public_html/cms/wp
=================================================

If I disable the WPML Media plugin, everything works fine and I can save the Formidable Pro View without problem.

Deleting and reinstalling the plugin didn't help.

September 11, 2019 at 7:49 am #4551177

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello!
Welcome to WPML Support.
I'll do my best to help you solve this issue.

By the looks of it, this seems like a compatibility issue.

Could you please install Formidable Pro in this sandbox site and try to replicate the problem as well: hidden link

If you replicate the problem in the sandbox site, please write here the steps to replicate the problem because if it is indeed a compatibility issue, our developers will need them (the steps) in order to find out where's the problem.

Regards.

September 11, 2019 at 9:38 am #4552193

Puntorosso

Hi, I have installed Formidable Pro in the sandbox, but couldn't replicate the problem.
Anyway, there are too many factors which are different in my site, first of all the different domain/language, which has shown to be one of the main compatibility problems in the past.

I am afraid you will have to check the live site.

Thanks

Best

September 11, 2019 at 2:36 pm #4554323

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

No problem, it's fine by me. at least we now know it's not a direct compatibility and that's a good thing!

Please make a backup of your site before giving me credentials to the site and then add the credentials on the fields i activated for you.

Regards.

September 16, 2019 at 9:49 am #4578267

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ok, i think the problem was just some content in the database.

I followed these steps and the problem seems to be fixed now:

Go to WPML -> Support -> Troubleshooting
Press the following buttons:
• "Remove ghost entries from the translation tables"
• "Set language information"
• "Fix post type assignment for translations"

and that fixed it.

Can you confirm please?

September 16, 2019 at 5:10 pm #4582817

Puntorosso

Yes it works!

Thanks a lot for your help.

Best