This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 25 replies, has 3 voices.

Last updated by Alejandro 4 months ago.

Assigned support staff: Alejandro.

Author Posts
June 6, 2019 at 9:53 am #3967943

Jaroslaw

Hi,
I was try to install WPML few times (more than 10). Always after installing plugins i have error.:
The site is experiencing technical difficulties. Please check your site admin email inbox for instructions.

I was payed for the working plugin - but still have problem with it.

Please fix the package of plugins or fix my website.
Actually i was manually remove plugins from FTP to have working website.
Send you login and data?

Link to testing server:
hidden link

Best of all
Jarek

June 6, 2019 at 10:07 am #3968013

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

Unfortunately i couldn't reach you on the chat, if you want, please open another one and i'll gladly help you out.

In the meantime please kindly Follow the instructions mentioned on this page: https://wpml.org/documentation/support/debugging-wpml/

Try to recreate the problem once you have added those lines to your wp-config.php file and then go to your installation's wp-content folder and find the "debug.log" file that should've appeared by now (it will appear if it enocunters an error in your server).

That is the first step we need to take, to check what exactly is causing this issue.

Then, upload that file into a storage platform of your choosing (Google Drive, Dropbox, etc) and send me the link (make sure it's set as "public" otherwise i won't be able to access its content) so i can download it and take a look at it, and determine where to go from there.

Regards.

June 6, 2019 at 10:17 am #3968177

Jaroslaw

So i'v maded steps to modify wp-config.php.

First i was installed file:
sitepress-multilingual-cms.4.2.6.zip and enabled it.

Here you have an error:
Fatal error: Uncaught exception 'InvalidArgumentException' with message 'element_id and type do not match for element_id:112 the database contains tax_action-group while this function was called with tax_category' in /home/platne/serwer24252/public_html/viola/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-set-language.php:32 Stack trace: #0 /home/platne/serwer24252/public_html/viola/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php(1490): WPML_Set_Language->set('112', 'tax_category', NULL, 'pl', NULL, true) #1 /home/platne/serwer24252/public_html/viola/wp-content/plugins/sitepress-multilingual-cms/inc/translation-management/translation-management.class.php(1942): SitePress->set_element_language_details('112', 'tax_category', NULL, 'pl') #2 /home/platne/serwer24252/public_html/viola/wp-content/plugins/sitepress-multilingual-cms/inc/translation-management/translation-management.class.php(1927): TranslationManagement->add_missing_language_to_taxonomy(Object(stdClass)) # in /home/platne/serwer24252/public_html/viola/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-set-language.php on line 32

The site is experiencing technical difficulties. Please check your site admin email inbox for instructions.

And content from: debug.log

[06-Jun-2019 12:16:17 Europe/Warsaw] PHP Fatal error: Uncaught exception 'InvalidArgumentException' with message 'element_id and type do not match for element_id:112 the database contains tax_action-group while this function was called with tax_category' in /home/platne/serwer24252/public_html/viola/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-set-language.php:32
Stack trace:
#0 /home/platne/serwer24252/public_html/viola/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php(1490): WPML_Set_Language->set('112', 'tax_category', NULL, 'pl', NULL, true)
#1 /home/platne/serwer24252/public_html/viola/wp-content/plugins/sitepress-multilingual-cms/inc/translation-management/translation-management.class.php(1942): SitePress->set_element_language_details('112', 'tax_category', NULL, 'pl')
#2 /home/platne/serwer24252/public_html/viola/wp-content/plugins/sitepress-multilingual-cms/inc/translation-management/translation-management.class.php(1927): TranslationManagement->add_missing_language_to_taxonomy(Object(stdClass))
# in /home/platne/serwer24252/public_html/viola/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-set-language.php on line 32

So what now?

June 6, 2019 at 11:57 am #3968989

Jaroslaw

Error was disapeard after few minutes. But i was try to install plugin:

Translation Management

After Install and turn i have an error:
Fatal error: Uncaught exception 'InvalidArgumentException' with message 'element_id and type do not match for element_id:106 the database contains tax_category while this function was called with tax_product_cat' in /home/platne/serwer24252/public_html/viola/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-set-language.php:32 Stack trace: #0 /home/platne/serwer24252/public_html/viola/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php(1490): WPML_Set_Language->set('106', 'tax_product_cat', false, 'pl', NULL, true) #1 /home/platne/serwer24252/public_html/viola/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-install.php(122): SitePress->set_element_language_details('106', 'tax_product_cat', false, 'pl') #2 /home/platne/serwer24252/public_html/viola/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-install.php(52): WCML_Install::set_language_information(Object(SitePress)) #3 /home/platne/serwer24252/public_html/viola/wp-content/plugins/woocommerce-multil in /home/platne/serwer24252/public_html/viola/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-set-language.php on line 32

The site is experiencing technical difficulties. Please check your site admin email inbox for instructions.

June 6, 2019 at 12:23 pm #3969223

Jaroslaw

I' changed name folder for this:
_X_wpml-translation-management

And backend is working - but still this is not a propper fix for error above. Waiting for help dear Alejandro.

June 7, 2019 at 10:15 am #3975499

Jaroslaw

Can you fix plugin? If you would like not to help i will gave this plugin one star on every market place where you have this one and describe how much this plugin can be mess in shop..

June 10, 2019 at 11:41 am #3987163

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

Sorry about the delay, for some reason this ticket didn't appear on my queue.

However:

1) there aren't "marketplaces" where you can buy this plugin, so you couldn't have "officially" rated the plugin anywhere else, at least not in marketplaces where you could download the plugin (they would be selling it illegally).

In order to fix this issue, could you please give me access (add them in the fields i just enabled for you, otherwise they will be public)

Please provide FTP access as well, because if the site breaks due to a plugin installation i cna quickly go back and fix it without harming your site.

Let me know when you do that.

Regards.

June 11, 2019 at 6:04 am #3992007

Jaroslaw

Hi,
Did you fix plugin?
I saw new errors after gave you acces.

Notice: Korzystanie z get_woocommerce_term_meta uznawane jest za przestarzałe od wersji 3.6! Zamiast tego użyj get_term_meta. */wp-includes/functions.php on line 4435

June 11, 2019 at 7:54 am #3993009

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

I tried several times and tried to login the problem but it seems there's something else in there.

If the site is not a production site, could you please try to disable all the plugins except all the WPML ones and see if the problem is still occurring? if it is, then the problem is most likely at a database level.

I tried logging the error but nothing seems to appear in there, so please also be on the lookout for a file called debug.log which is located in the wp-content.php folder.

Make sure the debug log is active by checking the following code on your wp-config.php file:

define('WP_DEBUG',true);
define('WP_DEBUG_LOG',true);
define('WP_DEBUG_DISPLAY',false);

That code should already be in the file because i added it yesterday (it was turned off before)

Let me know how it goes and if i can make more tests (i didn't want to touch stuff that coudl create issues in the front-end without your permission)

Regards.

June 11, 2019 at 8:06 am #3993147

Jaroslaw

Ok, i will disable plugins - and one again i should install all plugins again?
I have full back - files + database. So if you want to try some new - have to try.

I will modify wp-config and disable plugin - and will back with notification if still there are errors.

June 11, 2019 at 8:48 am #3993397

Jaroslaw

I was disabled all plugins, leaving only:
WP bakery, WMPL.

Site have error after install plugin: WPML translation management.

The site is experiencing technical difficulties. Please check your site admin email inbox for instructions.

SO you can now try to fix website.

June 11, 2019 at 8:53 am #3993409

Jaroslaw

Or maybe you would like to work on fully worked website?
I can recover all files and database.

tell me would you like to have.

June 12, 2019 at 9:10 am #4002247

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

At this point the best thing we can do is have the site migrated to our staging site, so i can have full control over the server and monitor more things and run more tests without messing up your site, your site's content and your site's database. I'll send the steps needed in another thread (a private one).

Regards

June 12, 2019 at 9:34 am #4002561

Jaroslaw

Can i send you package and database and you will install it?

June 12, 2019 at 9:54 am #4002719

Jaroslaw

So i was recoverd backup with working site and run migration.

The topic ‘[Closed] The site is experiencing technical difficulties.’ is closed to new replies.