This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: flatsome logo string is not appearing for translation into another language Solution: Use the following XML: Relevant Documentation: https://wpml.org/documentation/support/language-configuration-files/#purpose

This topic contains 5 replies, has 2 voices.

Last updated by Jody Wan 2 weeks, 2 days ago.

Assigned support staff: Bruno Kos.

Author Posts
September 30, 2019 at 7:02 am #4662535

Jody Wan

I went into the "Translate texts in admin screens »" and found the site logo under my flatsome child theme. I clicked the string but it is not appearing on the string translation page.

September 30, 2019 at 7:19 am #4662609

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you tell me if you tried clicking "Apply" at the bottom of the screen, after you selected the correct logo entry? Because clicking itself will not do, you need to apply these settings.

Regards,
Bruno Kos

October 1, 2019 at 7:42 am #4669217

Jody Wan

Yes, I did press the "apply" button at the end of the screen and the little circle was turning for a couple of seconds.

October 1, 2019 at 8:43 am #4669723

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

In order to debug this issue further quickly, would you be willing to provide me with temporary WordPress admin username so I could investigate the issue directly?

I will see if I can extract the field using custom XML configuration and multilingual tools plugin.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

I marked your next reply as private so that you can safely add credentials.

Please make a full backup of your site before sharing this info!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

Regards,
Bruno Kos

October 1, 2019 at 11:54 am #4671801

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I used the following XML:

<wpml-config>
  <admin-texts>
    <key name="theme_mods_flatsome-child">
      <key name="site_logo"/>
    </key>
  </admin-texts>
</wpml-config>

https://wpml.org/documentation/support/language-configuration-files/#purpose

And it appears now within string translation, within "admin_texts_theme_mods_flatsome-child" domain.

Regards,
Bruno Kos

October 1, 2019 at 12:14 pm #4671937

Jody Wan

My issue is resolved now. Thank you!