This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The stocks between different language are not synchronizing correctly.

Solution: Updating to the latest version and synchronizing again solved the problem

This topic contains 4 replies, has 2 voices.

Last updated by Rogier 4 months, 3 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
May 10, 2019 at 9:52 am

Rogier

Stock is not being synced between the different languages.

The english link is, the main language is dutch:
hidden link

Stock Dutch: 7
Stock English & German: -5

I don't use Variations.

I tried some of the Fixes you suggested on the forum, but with no luck.

If you need access, please let me know.

May 10, 2019 at 11:58 am #3783919

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

I would need your help to narrow down the issue. Could you please provide feedback on the following questions as much as possible?

#1
I can see that you are using an outdated version of WooCommerce & WooCommerce Multilingual plugins. Since we always add fixes and improvements in the latest version, could you please update the plugin to the latest version and let me know if this helps?

NOTE:

+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!). You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose. See: http://wordpress.org/plugins/duplicator/

#2
Once the update is completed, Go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting page link (bottom right) -> Sync the products.

#3
If the problem still exists, could you please perform the below steps and share me the results?

Debugging

1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

Look forward to receiving your answers so we can get to the bottom of this issue.

Thanks

May 17, 2019 at 5:29 am #3831483

Rogier

Hi Shekhar

Thanks for your reply, i will try to update the plugins.
Will get back to you once done.

Best regards
Rogier

May 17, 2019 at 10:34 am #3833435

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Sure, look forward to your reply.

Thanks

May 24, 2019 at 10:36 am #3883587

Rogier

After Updating to the latest version i was able to Sync the products. That fixed my problem.

My issue is resolved now. Thank you!