This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by ka-lunK 12 months ago.

Assigned support staff: Otto.

Author Posts
October 24, 2018 at 12:13 pm #2846137

ka-lunK

Hi Otto,

I don't know why it is ok now.
BTW, may I ask how to make the translated page have the same css style as default language page? As you can see I've only translated Home page from English and Traditional Chinese (TC). However, the heading and the background width of TC page showing different style from English page.
(Please let me know if I have to create a new post for this question.)

Best,
Lawrence

October 24, 2018 at 12:21 pm #2846174

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi Lawrence,

I am truly sorry, but I visited the homepage and couldn't notice any difference in the style.

I've recorded this screencast:
hidden link

Am I missing something?

Kind regards,

Otto

October 24, 2018 at 12:49 pm #2846242

ka-lunK

Hi Otto,

I'm sorry I just figured it out and didn't update here. So I have to go to dashboard, then go to "Home page", switch the dashboard(backend) to TC language, then choose the Astra settings from the right hand side.
Is there any faster way to do it like duplicate those settings from default language to the translate language?

Best,
Lawrence

October 24, 2018 at 2:14 pm #2846797

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Lawrence,

Thanks.

If you go to edit the page, at the end you will find a block "Multilingual Content Setup".

The style of the page is defined by some theme custom fields, so in the custom fields section, you should set those to copy. This way, you will have the same settings regardless of the language.

These settings affect not only the page you are editing but all the pages. You can also edit them in WPML > Settings > Custom fields

Let me know if this helps, please.

Kind regards,

Otto

October 24, 2018 at 3:20 pm #2847044

ka-lunK

Hi Otto,

Thank you Otto. Am I be able to edit specific page css by entering the page builder after copy all settings from default language?

Best,
Lawrence

October 24, 2018 at 3:36 pm #2847107

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Lawrence,

If you want to have different styles per language: "copy once" or "translate" are the best options.

If you want to have the same style per language: "copy" is the best because it will keep the styles in synch. If you change it for one language, changes will apply for all.

Here you have a deeper explanation of each option:
https://wpml.org/documentation/support/language-configuration-files/#custom-fields

Let me know if this points you in the right direction, please.

Kind regards,

Otto

October 24, 2018 at 6:36 pm #2847632

ka-lunK

Hi Otto,

Thanks for your help, but I think I need some time to figure it out. I feel comfortable as long as all warnings are cleared now.

BTW, please can you ask your development team to switch back the flag for Traditional Chinese. People like me are using both Simplified & Traditional Chinese got confused by looking at the flags. I have to wait a seconds to make sure I'm going to edit the right language.

Best,
Lawrence

October 24, 2018 at 6:53 pm #2847698

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi Lawrence,

Sure, take your time and let me know how it goes when you have the chance to try it.

Regarding the flag, you can change it:
https://wpml.org/documentation/support/editing-wpmls-languages-table/

Kind regards,

Otto

October 24, 2018 at 10:36 pm #2847957

ka-lunK

My issue is resolved now. Thank you!