This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Lauren 1 year ago.

Assigned support staff: Lauren.

Author Posts
October 14, 2018 at 3:57 pm #2815602

pengp

I have registered my copy of wpml. But a few days later the system asks me to register again.

October 16, 2018 at 2:01 pm #2821229

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

When you register the plugin, does the message temporarily go away, and then return a few days later?

Please create a backup of your database. Then, access your database and in the wp_options table, search for a field for wpml_notices. Then remove that row. After this, does the message return again?

If so, please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

1. Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

2. Browse to the page with the issue and/or reproduce the issue.

3. Locate the debug log in: /wp-content/debug.log

4. Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

October 16, 2018 at 2:01 pm #2821230

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

When you register the plugin, does the message temporarily go away, and then return a few days later?

Please create a backup of your database. Then, access your database and in the wp_options table, search for a field for wpml_notices. Then remove that row. After this, does the message return again?

If so, please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

1. Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

2. Browse to the page with the issue and/or reproduce the issue.

3. Locate the debug log in: /wp-content/debug.log

4. Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

October 17, 2018 at 3:37 pm #2825160

pengp

Thanks for the help. I have deleted the wpml options. And let's wait and see if it works. By the way when it reverts back I have to set everything up again and it breaks my site . Very annoying. Will there be an official fix soon?

October 17, 2018 at 5:21 pm #2825488

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

This is not a known issue, I think it is isolated to your site. I'm not sure why the message keeps popping up, but am hoping that clearing the notice from the database will resolve the issue. If the message comes up again, let me know and I will be happy to troubleshoot further.