This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 20 replies, has 2 voices.

Last updated by Carlos Rojas 8 months, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
January 11, 2019 at 8:30 am

mindbushD

I am trying to do a complete Portuguese translation. For some reason French worked, and i don't know how or why. When click on " Edit X Language ", it takes me to the "Advanced Translation Editor" but doesnt show me all the text. Funny thing is, all of the French page is translated, but in the "Advanced Translation Editor" i don't see all the text. Now, when I try to translate any other language, i cant see all the text to translate.

Link to a page where the issue can be seen: hidden link

I expected to see all the text on the site, but all the text within the text editor widget is missing...but somehow worked for French.

January 11, 2019 at 8:49 am
January 11, 2019 at 1:49 pm #3080946

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
My name is Carlos and I will be taking this ticket from now long.

I would like to ask you to follow this steps:
- Create a full backup of the site
- Update all outdated plugins and themes. Outdated functionalities can cause conflicts in the code.
- Flush all cache memory.
- Edit the page in the original language -> Make a small change to the text that doesn't appear in the Translation Editor -> Save the changes -> Update the translation.

Could you tell me the result of the steps above?

Regards,
Carlos

January 11, 2019 at 5:55 pm #3081672

mindbushD

I still don't see the fields in the "Advanced Translation Editor" after changing the text from "We're your bank card, your teller and your wallet, all rolled up into one app." to "We're your bank card, your teller and your wallet, all rolled up into one app.Red" -- i just added the word "Red" to the end and i dont see this field to update this text at all.

January 14, 2019 at 3:11 pm #3088358

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

Before we continue I need to ask you to update Elementor, there is a new version available. Please let me know if the issue persists after updating Elementor.

Regards,
Carlos

January 14, 2019 at 11:00 pm #3089972

mindbushD

Same results

January 15, 2019 at 4:37 pm #3093976

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your answer.
I'm sorry for the delay in my message, we had some technical issues in our side this morning.

I would like to ask you to follow this steps:
- Go to WPML -> Settings -> How to translate posts and pages -> Select Classic Translation Editor -> Save the changes.
- Edit the page in the original langage -> Make a small change -> Save the changes -> Update the translation.

Could you tell me if the issue persists withe the Classic Translation Editor too?

Regards,
Carlos

January 15, 2019 at 4:38 pm #3093996

mindbushD

Yes, the issue persists. Tried this multiple times.

January 15, 2019 at 6:26 pm
January 15, 2019 at 9:01 pm #3094791

mindbushD

No, feel free to edit the existing site. I have backups

January 16, 2019 at 4:36 pm #3098510

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your authorization.

I made this changes in the site and now it seems to be working correctly:
- I updated all outdated plugins.
- I went to WPML -> Support -> Troubleshooting link -> Applied some troubleshooting options.
- I went to WPML -> Settings -> How to translate pages and posts -> Selected 'Classic Translation Editor' -> Save the changes.
- Edited the page in the original language using Elementor -> Made a small change -> Saved the change -> Updated the translation.

Could you confirm that is possibe to translate all the elements in the page?

Regards,
Carlos

January 16, 2019 at 4:59 pm #3098665

mindbushD

How did you come to the conclusion that this is solved? can you include a screen shot showing that you are able to translate all text?

January 16, 2019 at 8:08 pm #3099336

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
I'm sorry I made a mistake, the issue still persists. Please accept my apologies.

The string I used for testing were already translated.

I'm consulting our specialists about this issue. I will get back to you as soon as I have an answer from them.

Thank you very much for your understanding.
Best regards,
Carlos

January 17, 2019 at 2:23 pm #3102415

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your patience.

I created a test site to reproduce the issue from scratch and been able to isolate in order to escalated to our 2n tier of support. I already installed WPML plugins (EN and FR languages) and I kindly ask you to install the necesary plugins and themes to reproduce the issue.

You can access the backend of this test site using the following link: hidden link

Please let me know when you reproduce the issue in the test site so we can continue debugging this issue.

Regards,
Carlos

January 18, 2019 at 10:18 pm #3107398

mindbushD

Forgive me. I want to understand. You want me re create the entire site? I already tried disabling all the plugins and tried using WPML and it was to no avail. No luck. You are welcome to try, but i'm not going to re create the entire site just to be told that it has to be escalated. Please escalate if you need to. This is day 9 and we still don't know why this plugin doesn't work even though you have full administrator access to the site, and authority to do what you need in the backend to trouble shoot.

Let please move this forward.

The topic ‘[Closed] The text within the "Text Editor" in Elementor is not getting translated’ is closed to new replies.