This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by vincenzoL-6 1 month ago.

Assigned support staff: Riffaz.

Author Posts
June 3, 2020 at 3:38 am #6278785

vincenzoL-6

Hello,
As you can see from the attached images the top menu is not working properly in the Japanese language. The website is hidden link

There are two issues in the Japanese language:
1. The top right side the Language text is not visible properly
2. The main top banner image is pushed down, creating a strange grey line and also making to top menu background black.

I am using the AVADA WP template. Could you let me now how to fix it?
Thanks
Vince

June 3, 2020 at 3:41 am #6278897

vincenzoL-6

I clicked on the I still need assistance button, but nothing happened

June 3, 2020 at 11:50 am #6282919

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

This is because the setting in the original page for the area is not copied to the translations.

1)
i. go to the original language page
ii. edit it
iii. scroll down to the section "Multilingual content setup"
iv. check if there is any field name related to header padding or margin or gap.
v. if you do not see any click on Show system fields and search again: https://wpml.org/wp-content/uploads/2020/05/6061919-Edit_Page_Elekfantz_WordPress_2020_05_05_18_51_56.jpg
vi. make it copy one.
vii. make small change in the page and update.
viii. click on translate and save.
now you should see the same setting in the translation page as well.

2)
you can find these in WPML > Settings > Custom Fields Translation

Please try and let me know the results.

Regards,
Riffaz.

June 3, 2020 at 1:13 pm #6283987

vincenzoL-6

Hi Riffaz,

Thanks for the message.
I did not understand well what you want me to do. I checked and everything seems fine.

I made a google document that shows my current "Multilingual content setup":
hidden link

Could you check it and let me know which check boxes I need to change?

There is another issue about point 8 in your previous message:
viii. click on translate and save.

I cannot find any where the option to TRANSLATE and SAVE. I see only UPDATE When do I need to go to do it?

Thanks,

Vince

Thanks

June 4, 2020 at 7:13 am #6290133

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Could you please create a temporary admin and let me know the username and password in the next private reply?

Regards,

June 4, 2020 at 1:21 pm #6294499

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the details.

In your translated page option the attached screenshot options were not same as your original page.
I made them same and now your English and Japanese pages layout/style is ideal.

Please check and confirm.

Regards.

June 5, 2020 at 12:39 am #6299447

vincenzoL-6

My issue is resolved now. Thank you!