This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Peter 4 months, 4 weeks ago.

Assigned support staff: Andreas W..

Author Posts
May 13, 2019 at 2:42 pm #3799529

Peter

I am trying to: Translate existing media in all languages

I expected to see: All media files in all languages.

Instead, I got: English media library has 332 images, Russian media library has 8 images.

May 13, 2019 at 8:57 pm #3801539

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

In order to translate media with WPML I would advise you to install our Plugin Media Translation. Go to Plugins -> Add new -> Commercial to download and activate it.

Then go to WPML -> Settings -> Media Translation and click the "Start" button in oder to sync your media.

Let me know if you need any further assistance.

Kind regards
Andreas

May 13, 2019 at 9:21 pm #3801641

Peter

Hi Andreas,

thank you for your quick reply!

I don't really want to translate them, I want to make all media files available for all languages, that's all. I have done the same setting before for other subsites with other languages.

My problem is now, that it is not working on a subsite. There are a lot of media for English language and I want to make them available for the Russian language also.

So it is something, I already did in the past, but it is not working right now.

May 13, 2019 at 9:46 pm #3801767

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

In order to duplicate Media you should go to WPML -> Settings -> Media Translation and click the "Start" button in oder to sync your media.
Does the option not respond or ends in an error?

In fact, this option will not duplicate the media physically, it will only duplicate entries in the database table and assign it to a respective language value.

Same goes with our Media Translation plugin.

Let me know if the "Start"" option at WPML -> Settings -> Media Translation solved the Media Library issue or please provided details about any given errors or unexpected behavior.

In doubt, please try to run the site in minimal setup to see if the issue persists.

Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.
More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

I am awaiting your response.

Kind regards
Andreas

May 14, 2019 at 5:33 am #3803711

Peter

> In order to duplicate Media you should go to WPML -> Settings -> Media Translation and click the "Start" button in oder to sync your media.

I know, how to do this, as I have written, I did it a lot of times in the same multisite network.

Clicking on the Start button doesn't give any error. The process is running without any problem, but it finishes too quickly. There should be more than 300 files to be synced, but it doesn't sync those media files.

> In fact, this option will not duplicate the media physically, it will only duplicate entries in the database table and assign it to a respective language value.

Once again: I know, what I'm doing, as this multisite has 17 sites and I did the same synchronization on more sites already. I don't want to duplicate the files, I only want to make them available with the "Translate existing media in all languages" option enabled.

So there is no need for PHP debug or error checking, the process is "working", but it doesn't do its job on this subsite.

I hope, you really understand my situation now!

May 14, 2019 at 3:04 pm #3808471

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

May 17, 2019 at 4:05 pm #3835877

Peter

The necessary fields are missing. I made a staging site, where you can see the problem and do whatever you want. I'm waiting for the possibility to add all the necessary informations securely.

May 17, 2019 at 9:39 pm #3837069

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

May 18, 2019 at 1:03 am #3837395

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

As far I can see you did not enable the checkboxes for enabling media duplications for translations. I have enabled these options on the Russian Site and scanned again for Media.

The Russian Media Library here includes now 28 files which are based on content that indeed had been translated into this language.

I understand right that you expect to have the English Media Library Content available in all languages?

I so, I will consult my colleagues about this on Monday, specially about how this relates to Multisites. As far I know the behavior of your site and media is default bahvior and maybe it would be advisable to make a feature request here.

I will be in contact with you soon.

Relative documentations:
https://wpml.org/forums/topic/new-wpml-4-0-4-beta-solves-media-issues/#post-2441636
https://wpml.org/forums/topic/make-media-library-available-in-all-languages/

Kind regards
Andreas

May 19, 2019 at 5:44 pm #3842189

Peter

Andreas, I feel, you don't listen to me. As I have already written, I've already used this option in this Multisite network. So on other sites, the same steps were done and all media was available for added languages after this option.

So please understand, that I'm using it for a while without any problem. Only the Russian site doesn't do it, as I want. So it can be done in a Multisite environment, as I've already done it.

May 20, 2019 at 3:27 pm #3848309

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello Peter,

I am sorry for the misunderstanding.

Did you already try to run the wp-debug feature to obtain a debug.log file?

Please add/edit the following inside of the wp-config.php file:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', true );

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

This will display errors on front end and backend and further create the debug.log file inside of the wp-content folder. Please provide me the results.

More information here: https://wpml.org/documentation/support/debugging-wpml/

It might be that the issue is caused due to a database error. Could you further take abackup and run the Clean Up Options at WPML -> Support -> Troubleshooting:

- Remove ghost entries from the translation tables
- Fix element_type collation
- Fix WPML tables collation
- Set language information
- Fix terms count
- Fix post type assignment for translations

Kind regards
Andreas

May 28, 2019 at 9:07 am #3904573

Peter

I just found the problem. There was a third language for this site and media files were attached to that language. I needed to enable that language, so I was able to sync all media across the languages.

My issue is resolved now. Thank you!