This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by Franco 3 weeks, 3 days ago.

Assigned support staff: Andreas W..

Author Posts
September 17, 2019 at 10:53 am

Franco

I am trying to:
I checked by disabling all plugins and with WP theme. The translation of the Author role was already enabled.
Link to a page where the issue can be seen:
hidden link (HTTP AUTH: alberto / wise-ducks)
I expected to see:
The translation in Italian appears instead of in English. On string translation the description is already correctly translated.

September 17, 2019 at 11:09 am
September 17, 2019 at 9:56 pm #4591161

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

The _author-bio.php is based on the theme or is this custom work?

In case is a custom work, please take note that our support policy does not cover support on such tasks.

I would refer you here to our Hooks reference or aks you to contact a contractor.

Relative documentations:
https://wpml.org/purchase/support-policy/
https://wpml.org/contractors/
https://wpml.org/documentation/support/wpml-coding-api/wpml-hooks-reference/

In case this file is based on the theme and/or its plugins please install the theme and its plugins on the following test site for further investigation:

One Click Login:hidden link

Leave me a short notification once the site is ready for testing.

Kind regards
Andreas

Kind regards
Andreas

September 18, 2019 at 7:04 am #4592815

Franco

Hi Andreas,

Sorry, I had to delete that file.
In the installation you sent me, I installed my theme with its child "Total" and the "Total theme core" and "Classic editor" plugins.

I am attaching a screen of the String Translation with the translation correctly inserted, but which is not shown in the frontend.

Thanks

September 18, 2019 at 3:28 pm #4598157

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for installing the themes. I tested with the Child theme and there was no problem to translate the author bio.

Could you please try to run the site in minimal setup to see if the issue persists?

Please disable any additional plugin that is not related to WPML and its add-ons.

If the issue disappears please start reactivating any plugins, or activate them in small groups.
This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Once you located a plugin causing the iossue please add it to our test site and leave me a notification.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.

Add the following to your wp-config.php file:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

You will be able to find a complete report inside of your wp-content folder. Look for a debug.log file and provide me the results.

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Let me know about the outcome.

Kind regards
Andreas

September 19, 2019 at 8:54 am #4602733

Franco

Hi Andreas,

As you can see in this example article hidden link the situation remained the same after performing these operations:

1) activated the WP theme;
2) disabled the last active plugins;
3) disabled and re-enabled WPML and its addons;
4) enabled display debugging and no error is detected.

September 19, 2019 at 9:35 pm #4608355

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message. I have been troubleshooting the site again and tried to apply the same setup and settings as on the working testsite.

In fact, so far I do not find any differencies between the working testsite and the staging with the error. They only vary slightly in their PHP version and in the used PHP and WP Memory.

I would like to request FTP access in order to debug the site myself. In case you are not able to provide FTP access I can offer to migrate your site to our test server.

Further, I would advise to try to edit the following lines inside of the wp-config-file:

/** Enable Cache by WP Rocket */
define( 'WP_CACHE', false );

If this will still not solve the issue I will need to escalate the site to our deveopers.

Kind regards
Andreas

September 20, 2019 at 7:18 am #4610133

Franco

Hi Andreas,

Unfortunately I cannot make migrations or provide a dedicated FTP access.
But I installed a File Manager plugin for browsing and editing files. It is OK?

Regards

September 21, 2019 at 2:09 am #4614727

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for the message.

I am not sure why, but the file manager does only show me a empty wp-config file. In order to investigate the issue I took a copy of the website with Duplicate in order to debug locally.

I hope it is ok with you, if I contact you on monday, as I had a higher workload today than expected. In case I will not find a solution I will then escalate the issue to our second tier or to developers accordingly, if necessary.

Kind regards
Andreas

September 23, 2019 at 7:26 am #4621087

Franco

Hi Andreas,

Thanks for the support.
The wp-config file I believe is not accessible/editable for security reasons by the hosting (Flywheel).
Alternatively, I can ask FW support to make changes to the file that you will tell me.

Regards

September 24, 2019 at 1:26 am #4627001

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

I am at this point consulting our second-tier support for a solution.

Could you please ask Firefly to check if the issue is related to WP or Server Cache?

Kind regards
Andreas

September 24, 2019 at 9:15 am #4629505

Franco

Hi Andreas,

Thanks, I have now opened a ticket with their assistance to investigate the cache servers, I will update you as soon as I have an answer.

Regards

September 24, 2019 at 12:00 pm #4631395

Franco

Hi Andreas,

Flywheel's technical support has confirmed that this is not a cache server problem

September 24, 2019 at 2:56 pm
September 24, 2019 at 2:58 pm #4632583

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

While we are waiting for our second tier to have a look at the issue please have a look at my last private message and follow the instructions in order to migrate the site to our test server.

This way we will be able to test the site in a different environment.

Leave me a short notification once the site is migrated.

Kind regards
Andreas