Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:The translated Home Page link is redirected to wrong page

Solution:I have inspected your URL and found a 301 Redirect present for the /ar/ URL.

As you use Yoast please go to Yoast->Redirections->301 Redirect and inspect in case there is an active redirect for the /ar/ URL.

Relevant Documentation:

This topic contains 2 replies, has 2 voices.

Last updated by mahmoodR 1 month ago.

Assigned support staff: Bobby.

Author Posts
November 7, 2019 at 5:41 pm

mahmoodR

I am trying to: switch the main language (English) to the second language (arabic) by clicking the Arabic flag on the home page language switcher

Link to a page where the issue can be seen: hidden link

I expected to see: the Arabic language of hidden link

Instead, I got: hidden link
Please Note that when I change the Language URL format in WPML language setting to be ?(lang=ar) instead of (/ar) at the end of the URL works fine, just (/ar) give a wrong page only for Home page but other pages and posts are ok without any issues.

November 7, 2019 at 7:59 pm #4909873

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

I have inspected your URL and found a 301 Redirect present for the /ar/ URL.

As you use Yoast please go to Yoast->Redirections->301 Redirect and inspect in case there is an active redirect for the /ar/ URL.

Please review the following redirect results below:

hidden link

HTTP/1.1 301 Moved Permanently
Date: Thu, 07 Nov 2019 19:55:22 GMT
Server: Apache
X-Redirect-By: Yoast SEO Premium
Location: hidden link
Content-Length: 0
Content-Type: text/html; charset=UTF-8

hidden link

HTTP/1.1 301 Moved Permanently
Date: Thu, 07 Nov 2019 19:55:24 GMT
Server: Apache
X-Redirect-By: Yoast SEO
Location: hidden link
Content-Length: 0
Content-Type: text/html; charset=UTF-8

hidden link

HTTP/1.1 200 OK
Date: Thu, 07 Nov 2019 19:55:28 GMT
Server: Apache
Last-Modified: Wed, 30 Jan 2019 11:09:17 GMT
Accept-Ranges: bytes
Content-Length: 120482
Content-Type: image/jpeg

November 8, 2019 at 1:20 pm #4913681

mahmoodR

My issue is resolved now. Thank you!