Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Cristina 4 years, 6 months ago.

Assigned support staff: Cristina.

Author Posts
April 3, 2017 at 11:04 am #1245635

davide-vitoP

The translated pages (english) give 404 or are not found.
I tried with all hyperlinks parameters, however, do not work the same.
I'm working on a demo, and until it does not work in the test can not be applied in the final WPML site.

Please help

April 4, 2017 at 3:13 pm #1247021

Cristina

Dear customer,

To ensure this is not a temporary problem please do the following first:

Go to WPML >Support >Troubleshooting link and use the following options in the “clean up” section of that page:

-Clear Cache in WPML
-Remove ghost entries from the translation tables
-Fix element_type Collation
-Set language information

The go to Settings > Permalinks, re-save your settings and check if it works.

If the problem still persists, please check the following:

What URL structure did you choose for the language URLs?

Please take into consideration that if you choose to add a language name as parameter and your permalinks are set to plain (like in .com?p=123) you may get conflicts with URLs.
The plain permalink structure may work with the parameter only and even not in all cases.
You may need to re-save permalinks if you changed the URL structure a few times.

Are the translated pages linked as translation to the original content?

You can check this by listing the pages and posts and checking the translation status.
If there are contents that have lost the translation connections they may not be found.

Are all translations marked as complete?

You will see this if you check the icons for the translation. If it is a pencil it means you have a completed translation linked to a page or post.
If the translation is not marked as 100% completed you will see a gear icon similar to a loading icon, and you may also get a 404.

Did you install your demo site with WPML inside a multisite installation with network sites in folders?

This could have conflicts with language directories in subfolders.

And finally, please test your translations with all non-WPML plugins deactivated and the default theme active to make sure this is not a compatibility issue with any theme or plugin.

If nothing of this applies or works, or if you think it is a compatibility issue, we will need some more information about your specific case.

In order to specify the exact cause of your problems, please send us the debug info for your site. To do this, please go to WPML > Support and click on debug information link at the bottom of the page.

Once on the debug information page, select the entire content of the text and copy it.
Please select the checkbox “provide the debug information” and paste the text into the text area. This way we will get a bit more information about your installation, like server type, WordPress version, plugins and theme versions.

Thanks in advance and kind regards,

Cristina

The topic ‘[Closed] The translated pages give 404 or are not found.’ is closed to new replies.