This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 3 voices.

Last updated by Bigul 3 months, 1 week ago.

Assigned support staff: Bigul.

Author Posts
June 12, 2019 at 1:58 pm

jeromeV-7

I am trying to: see translated pages in english

Link to a page where the issue can be seen:XXX/en/our-whiskies/

I expected to see:the page in english

Instead, I got:the page in french

June 12, 2019 at 6:37 pm
June 12, 2019 at 6:38 pm #4007061

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above. Thanks!

June 12, 2019 at 8:02 pm #4007405

jeromeV-7

Hi Marcos, thanks a lot for your help.
The migration is complete - hope nothing serious is happening.
Best regards,
Jerome.

June 14, 2019 at 2:13 am #4017565

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the details. I am jumping here to let you know I am currently troubleshooting your issue, I will let you know as soon as I have a more accurate and detailed answer. For now, I noticed when switching to the WPML Classic Translation Editor and resaving the translation, it apppears properly in the english page as you can notice at: hidden link however, I still need to make some more tests in order to determine it. Thank you for your patience and understanding. Have a nice day.

June 14, 2019 at 7:50 pm #4023953

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for your patience while waiting. I took some more tests in your website using the migrated copy and here is what you should try in order to fix this issue.

1 - In your WordPress Dashboard > WPML > Settings > How to translate posts and pages and temporary change to the WPML Classic Translation Editor.

2 - Now, in your WordPress Dashboard > Pages click to edit the default language page where you see the missing translation and make a minor editing in this page, save it.

3 - Click to edit the translation and check all the fields in order to make it 100% complete, save it and you should be done.

The purspose of the steps above is to force a refresh in your translation jobs and this way make them appear in your website frontend. You can see the results of these steps at:

hidden link
hidden link

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

Please, let me know if it works for you. Have a nice day.

June 19, 2019 at 4:00 pm #4053105

jeromeV-7

Hi Marcos,
I've tried to follow exactely these steps but it does not change anything for me on the website.
I've change to classic editor, modified pages, edited translation, and nothing happens, all english pages show in french.
I've noticed that on the online website, two pages show in english : our whiskies and spirits, but not the homepage for example.
Would it be possible for you to investigate further ?

June 20, 2019 at 3:35 pm #4061037

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. For some reason there's a kind of 'cache behavior' for your translatons in your website, the mentioned troubleshooting works properly when using the migrated copy in our test environment. I've forwarded your ticket to our second level support in order to get some more details of what's happening in your particular case, I will update you here as soon as I get some more information from them. Thank you for your patience and understanding. Have a nice day.

June 21, 2019 at 12:17 pm #4067105

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I am Bigul from WPML support team. Marcos is off today. So I am taking care of this ticket. Hope it will be okay for you.

We have a request. Please try the following troubleshooting steps on your site after a full site backup and make sure the issue is existing or not.

1) Please upgrade WooCommerce Multilingual and WPML Translation Management plugins to the latest version
2) Go to WPML>>Support page
3) Click on Troubleshooting link (blue link in the middle of the page)
4) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

If the exists, please check you are getting any error/warning related to this in the Server(Apache) error log.

--
Thanks!

Bigul

June 27, 2019 at 2:27 pm #4100821

jeromeV-7

Hi Bigful,
I've done exactely what you said and the website still has the wrong behaviour.
Nota : when I clic "fix WPML tables collation", it is the only step where the mouse cursor is turning (thinking) but I have no pop-up confirming that the job is done.
Maybe I should backup all the translations and re-install the plugin ? Is there a way to back-up all what has been translated ?
Best regards, Jerome.

June 27, 2019 at 4:58 pm #4101705

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Jerome,

Thank for the updates. There are limitations to backup only the translations. Please check you are getting any error/warning related to this in the Server(Apache) error log.

Also please share with me the WordPress debug.log (not WPML debug information) for more details.

Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

July 10, 2019 at 1:59 pm #4181025

jeromeV-7

Hi, please do not close this ticket, the problem is not solved - I just haven't had time lately to follow the instructions. Thanks

July 10, 2019 at 2:24 pm #4181431

jeromeV-7

Hi,
I've activated the debug mode.
Here's the debug log : https://pastebin.com/q8iEKRkK
I've been on various pages, switched from french to english language.
I've been to the back office, added the page "Gin" to the translation basket, been to the translation queue, ticked all the check boxes and saved, been back to the website and still nothing new :/
Thanks for your help.

July 11, 2019 at 7:58 am #4186999

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Jerome,

Thank for the updates and Debug log details. The Debug log is not showing any warning or error related to WPML. Therefore I have a request. Please upgrade to the latest version of Divi theme and Divi Builder after a full site backup. Also, upgrade related plugins to the latest version.

Then clear all types of caches including the server cache and make sure the issue is existing or not.

If the issue exists, please check you are getting any error/warning in the Server(Apache) error log.

--
Thanks!

Bigul

The topic ‘[Closed] The translated pages show in french instead of english’ is closed to new replies.