This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
March 21, 2019 at 10:52 am #3398441

daokunC

I've translated some necessary strings into Chinese and German, but unfornately, they are not appeared in the website. I do not know why. Maybethere are still something missed.

However, if I used the Advanced translation editor to translate pages, it works. but if I used "string translation” to translate page, the translated texts can not be displayed in the website.

For example, I translated the string "beaver-builder-156", but the link "hidden link" (homepage) were not localized.

Looking forward to your reply.

Best Regards,
Ken

March 21, 2019 at 11:52 am #3400683

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

- I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Could you please try to re-save the translation:

1. Go to WPML >> String Translation >> Search and Open your translated text >> delete the translation >> Save.

2. Then again go to: String Translation >> Re-add your translated text >> and re-save. Make sure that "Translation is complete" checkbox is selected.

3. Please delete all sort of caches on your site / server cache if any / plugin cache / CDN cache (if any), clear browser cache and then see if it resolves the issue afterwards. You can also disable cache plugin temporary while you update this string.

Thank you

March 21, 2019 at 9:42 pm #3424729

daokunC

Thanks for reply.Actually, it does not work even though I followed your instruction.

Change a question, can I use string translation for the website content?

Because when we translate the page with the Advanced translation editor using, everything goes well. but if we use string translation, the translated texts were not displayed.

March 22, 2019 at 10:30 am #3439385

daokunC

One of your colleague told me that I should not use string translation for content translation (page)..

One more thing, for the domain "Features section", the string below can not be shown correctly.

"At all stages of the service, our staff is on call. If you have any requests or questions that we need to assist, whether it is within the scope of the service or additional needs, you can contact us via email, telephone, or whatsapp."

I've already translated it, but in the Chinese website, it is still English texts.

Same problem happened in another string "Speaking local languages<br />to sell more stuff." in the domain "Slider section".

Could you please help?

Thank you

March 24, 2019 at 2:38 pm #3448403

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

WPML String translation plugin is used to translate static texts and user-generated texts that are outside of posts and pages. For example, the tagline, widgets, theme options and SEO data.

To further debug string translation issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

The topic ‘[Closed] The translated texts of strings can not be displayed in the site.’ is closed to new replies.