This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 0 replies, has 1 voice.

Last updated by unid-communication-gmbhC-2 1 month, 3 weeks ago.

Assigned support staff: Laura.

Author Posts
August 23, 2019 at 9:07 am #4445629

unid-communication-gmbhC-2

Tell us what you are trying to do?

Hi guys, thank you very much for your help.
So I've got this page, already set up in German and English with the German site being the main one. Maintenance mode must still be on. The websites are one-pagers, with anchor tags for the menu with individual links. (www.example.com/#home). While both sites are working fine separately, I can't make the language switch from German to English work. it always goes to the wrong link and it seems I cannot change the permalink.

the main address is:

hidden link

At the moment I'm using the parameter URL format (hidden link)

The English version of the website responds to the URL
hidden link

And I can't get rid of the page_id tag.

Can I just give a custom link to the Language selection button?

Thank you so much for your help.

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?

The topic ‘[Closed] The translated website's permalink doesn't want to be the one I'd need’ is closed to new replies.