Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: There are some chains which I can't find to translate but the main problem is when the user is logged in or not.

Solution: - WPML > Languages. - Language filtering for AJAX operations And select the following checkbox: x Store a language cookie to support language filtering for AJAX

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Eduardo Torres Chacon 4 years, 4 months ago.

Assigned support staff: Andrés.

Author Posts
July 27, 2017 at 3:18 pm

Eduardo Torres Chacon

I am trying to: have this website in 3 languages. There are some chains which I can't find to translate but the main problem is when the user is logged in or not. For eaxample, in the page hidden link, when your are going to book an appointment, in the English version, you can see the text in English only if you are logged in. If you aren't logged in, you'll see the text in Spanish.

Link to my site: hidden link

I expected to see: well-translated texts in each languages independently if you are logged in or not.

Instead, I got: When you are not logged in, you can't see the translations.

July 27, 2017 at 3:35 pm #1329005

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hello Eduardo,

Welcome to WPML support forum.

This situation may be related to the following setting. Could you please go to:
- WPML > Languages.
- Language filtering for AJAX operations
And select the following checkbox:
x Store a language cookie to support language filtering for AJAX

Does it solve your issue?

Best regards,
Andrés

July 27, 2017 at 3:49 pm #1329031

Eduardo Torres Chacon

Yeah! Thanks!