This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Itamar 2 months ago.

Assigned support staff: Itamar.

Author Posts
July 27, 2019 at 7:29 am #4292887

Henk

I am trying to:
The translations are all gone and giving a 404 error. The only solution is to edit the page and then go translation, click that the translation is ok, and than click on edit.
Also the translation of the homepage and widgets are gone.

Link to a page where the issue can be seen:
hidden link
hidden link several products.
English: hidden link

I expected to see:
Dutch: hidden link

Instead, I got:
English: hidden link

July 27, 2019 at 7:51 am #4292907

Henk

I am now doing the translations again by marking the checkbox again, but the edited product are coming as newest now. In order to fix that I have to go to quick edit and save.

A lot of work but needed since I got complaints from my international clients.

July 28, 2019 at 5:47 pm #4295815

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I'm not sure that I fully understand the problem on your site. Could you please give me access to your website and explain to me exactly how to see the problem?

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

August 8, 2019 at 8:36 pm #4365835

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the access details.

I've checked things on your site and found out the following. The translated product that was having this problem was set to the status of Scheduled. Please see the attached screenshot scheduled-status.png. So here is what I did.
1. Go to WPML -> Settings -> Posts and pages synchronization
2. Check the 'Copy publishing date to translations' option. Please see the attached screenshot copy-pub.jpg
3. Save the settings.
4. Update the original product in Dutch and then the translation into English.
Now when I check hidden link even if I'm not logged in, I can see it.

Can you please confirm this and tell me if you have any questions?

Regards,
Itamar.

August 9, 2019 at 6:01 am #4367487

Henk

Hi Itamar,

Thank you! About step 4, if it is set in the settings it is not needed anymore, correct?

Henk

August 12, 2019 at 10:25 am #4380011

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Henk.

Sorry for forgetting to mention this, but, yes, of course, if the 'Posts and pages synchronization' is checked already you don't need to check it.

Please let me know if you have any further questions about this issue or mark this ticket as resolved.

Thanks,
Itamar.