Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by Bruno Kos 8 months, 1 week ago.

Assigned support staff: Bruno Kos.

Author Posts
December 3, 2019 at 8:46 am #5058389

ahmadA-28

Tell us what you are trying to do?
the translite unavlabile in home page

What is the link to your site?
hidden link

December 3, 2019 at 12:07 pm #5060345

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

As per our chat, I marked your next reply as private so that you can safely add credentials (once you have made the site backup).

So just to make sure, you want:
https://wpml.org/documentation/getting-started-guide/language-setup/language-url-options/#languages-in-directories

Please check this with your host as well:
https://wpml.org/faq/server-setting-for-languages-in-directories/

This needs to be set properly.

""""""""""""""
For this to work, Apache’s rewrite module must be enabled and the site needs to use a ‘fancy’ permalink structure (e.g., anything different than the default permalinks).
""""""""""""""

Regards,
Bruno Kos

December 3, 2019 at 5:44 pm #5063421

ahmadA-28

hi

December 4, 2019 at 11:01 am #5067535

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you try checking your server settings and consulting with your hosting about solutions?
https://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/

This is what is happening in your site, I am assuming it could be also some sort of a rewrite rule existing within htacces also, causing /en/en added in URLs. Can you check there as well?

Because this isn't working:
hidden link

As a last resort, can you please check if this issue appears when:

- only WPML plugins are activated, as it will tell us if there is an interaction issue with other plugin
- theme is set to a WordPress default like Twenty Nineteen as it will tell us if there is an interaction issue with your theme

Maybe it is one of the plug-ins causing these redirections, we need to determine which one.

Regards,
Bruno Kos

December 4, 2019 at 2:00 pm #5069341

ahmadA-28

Hi,
I try check your server settings
When i go to MyDomain/en?____icl_validate_directory=1
I see by looking at the page’s source) is:
<!--/en-->
and I try all of this
- only WPML plugins are activated, as it will tell us if there is an interaction issue with other plugin
- theme is set to a WordPress default like Twenty Nineteen as it will tell us if there is an interaction issue with your theme
and there is no result

December 4, 2019 at 3:00 pm #5069995

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can I ask you the following then? In order to debug this issue , I will install Duplicator plugin, will create packages and will try this on my localhost and possibly escalate further to 2nd tier.

https://wpml.org/faq/provide-supporters-copy-site/

Let me know if this is OK with you.

Regards,
Bruno Kos

December 4, 2019 at 8:23 pm #5072455

ahmadA-28

OK I will do it

December 5, 2019 at 8:03 am #5073979

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you double check with your hosting company support whether this is all correct?
https://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/

It is definitely not working properly on your site and until this is resolved, there isn't much I can help with. We (WPML support) cannot interfere with any server settings, this is up to clients and especially hosting support.

Because I restored the website on my localhost, what have no caching of any kind.

Have a look at this video, this is how the site looked like immediately after I restored it and changed the language URL format.
hidden link

So everything works outside of the box, I see no messages or errors of any kind and didn't change anything. It could also be some sort of a permission issue on your server-side or some rewrite rule happening somewhere on the server level as well, I cannot be more precise I'm affraid.

Regards,
Bruno Kos

The topic ‘[Closed] the translite unavlabile in home page’ is closed to new replies.