This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Please make sure to update to WPML to the latest and check our list of Known Issues before reporting

This topic contains 15 replies, has 2 voices.

Last updated by hectorV-3 8 months, 2 weeks ago.

Assigned support staff: Bruno.

Author Posts
June 26, 2019 at 4:26 pm #4094057

hectorV-3

I am trying to:translate a string

Link to a page where the issue can be seen:

I expected to see:trasnlated string

Instead, I got:untranslated string

June 26, 2019 at 7:08 pm #4094731

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. I would be very happy to help you but I didn't fully understand what is the issue.

After translating the string, does any error message appear? Can you please elaborate a little more so I can better understand? Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit so if you like make use of "upload an image" below the comment area.

Thank you.

June 26, 2019 at 8:17 pm #4095007

hectorV-3

Sorry, the problem is that after having updated the version of wpml (yesterday) all the strings that I had translated with wpml string translator appear without translating, it is very simple but very real.
This component of wpml (string translator) was working fine until I updated the version. This happens with all the string that I translated a few days ago from English to Spanish

June 29, 2019 at 4:53 am #4111075

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for the explanation. I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please let me know exactly what steps should I follow to see the problem.

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

July 1, 2019 at 8:33 pm #4122087

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. When I try to access your site it appears that the credentials are incorrect. I'll attach an image for you to see.

Please, could you check? If necessary, you can edit your previous private message, which will be highlighted for you.

Thank you.

July 1, 2019 at 9:11 pm #4122171

hectorV-3

Hi, Bruno
Sorry, try again with the same credentials

July 3, 2019 at 10:47 pm #4139273

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. I can now access your website. Please, could you tell me an example of a string that you have translated that is not being displayed? Looking at your site I see that it has a strings "Not translated" and a string "Translation complete".

Also, do you have the backup of your site before you upgrade?

Thank you.

July 4, 2019 at 1:21 am #4139399

hectorV-3

ok, look at this photo of the home page and the marked texts. These chains and many others have the complete translation. please ask them to give priority to solving the problem as much as possible, if it were essential, I could send a backup, but in these days we will have many tasks and do not have time to send it. Then as I said I need WPML support so that the site can be finished in time. Thanks

July 8, 2019 at 11:15 pm #4166075

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. These strings are probably not being translated by how they are being added. In the case, from what I've noticed, you're using a custom HTML using the shortcode of menus that were created in Appearance > Menus.

To resolve this problem you will need to duplicate these widgets and update the shortcodes for each language. I'll attach two pictures for you to see how this should be fixed.

Check the attached images and see how you can duplicate each widget and configure it according to your needs.

Note that this should be fixed this way because you are calling a widget within a shortcode which is also a widget. Therefore, the above steps are required.

Thank you.

July 9, 2019 at 3:45 pm #4172753

hectorV-3

Support We have been dealing with this problem for several days and we really do not have the right answer yet.
The example that I sent previously of string that were not translated is only 1% of all the string that were already translated and after the update stopped being it.
I can send hundreds of string examples that were already translated, please re-state that before the wpml plugins were updated, 80% of our strings were translated, including external plugins such as woocommerce.
At this time we have nothing translated and the only response we have had is to double the widget, please check again in a deeper way.
I attached the image of this url, can click on any product and check that most of the strings were translated and do not show that way.
hidden link

July 9, 2019 at 3:51 pm #4172807

hectorV-3

The first example that I sent you from the home page, was translated before the wpml update was done, so I ask you.
How is it possible that it worked well before and now does not ...?
Please something that you have not yet detected is happening, try to duplicate the site in your environment and do the tests you need, regards

July 13, 2019 at 1:25 am #4201921

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Sorry for the delay. I'm in touch with 2nd tier support so they can check out your site as well.

As soon as I have an answer from them, I'll keep you posted.

Thank you.

July 23, 2019 at 3:10 pm #4267349

hectorV-3

It is unfortunate that more than 10 days have elapsed and we do not yet have a successful response of our problem. In the current world, competitive is essential for any business. Our team is suffering the consequences of a non-efficient support service, please we have apart in you and bet on your product, but we need a prompt response, thank you

July 23, 2019 at 5:10 pm #4268375

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

First, my sincere apologies for the delay. At the moment, our 2nd tier support team has already seen the problem and we already know it will be fixed in a future version of WPML and WPML String Translation.

I am currently contacting 2nd tier support to see if there is any workaround for this meanwhile. I'm still waiting for their response. As soon as they answer me I will contact you.

Thank you.

July 23, 2019 at 6:32 pm #4268625

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

The 2nd tier said this will be fixed in a future version of WPML. This, in fact, seems to have been a compatibility issue with your theme.

Your theme is using native functions to return translations, and this may have caused the problem from an older version to the latest stable version of WPML.

We tested with the next WPML/String Translator version and it worked as expected. However, the theme is not at our compatibility list (https://wpml.org/documentation/theme-compatibility/), so it's better to invite the authors to join our go-global program: https://wpml.org/documentation/theme-compatibility/go-global-program/

Please note that we currently do not have a workaround to fix this issue - other than waiting for the next version of WPML/String Translation. If you want to test, you may be able to download previous versions of WPML plugins: https://wpml.org/account/downloads/ - clicking on the "i" icon next to the current version will bring you to the changelog list, where you can download previous versions.

Thank you.