This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by spring-and-autumnI 3 months, 1 week ago.

Assigned support staff: Rohan Sadanandan.

Author Posts
July 10, 2019 at 10:40 am #4178807

spring-and-autumnI

Hi there,

I'm using a custom theme (hello-theme for Elementor) and a CPT that I built with Toolset.

In the archive for the CPT, the title doesn't translate.
The code in the theme looks like this:

<?php the_archive_title( '<h1 class="entry-title">', '</h1>' ); ?>

A similar problem was adressed in the following thread already, but the anwser doesn't help in my case:

https://wpml.org/forums/topic/the_archive_title-is-not-translating-in-my-custom-theme/

What's wrong?

July 10, 2019 at 12:36 pm #4180299

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for contacting WPML Support.

The Archive Title can be translated using String Translation.

You can find the string "Produkte" in WPML > String Translation and you can translate from there.
If it doesn't work please post the screenshot of string translation showing the title.

You can read more about String Translation here: https://wpml.org/documentation/getting-started-guide/string-translation/

Thanks,
Rohan

July 11, 2019 at 8:16 am #4187249

spring-and-autumnI

Hi Rohan,

thanks.
I checked the string translation and there's the following problem:
The original language of the CPT is German, but the strings are marked as English (see attached image)...

July 11, 2019 at 10:53 am #4188853

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

By default, the strings in the String Translation are in English.

If you want to change the default language of a string, you need to:

1. Navigate to WPML > String Translation
2. Select the specific string checkbox
3. Click on the dropdown "Change the language of selected strings" at the bottom of the list
4. Select a language from the dropdown

NOTE:
Also, make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Thanks,
Rohan

July 11, 2019 at 4:42 pm #4192029

spring-and-autumnI

My issue is resolved now. Thank you!