This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by Radu 3 months, 2 weeks ago.

Assigned support staff: Radu.

Author Posts
June 13, 2019 at 10:24 am

simonH-30

I am trying to:
Translate the admin theme strings. All admin strings are translated and marked as complete in the string translation editor.
Strings are in "admin_texts_theme_mods_cleanportfoliopro"

Link to a page where the issue can be seen:
need to be logged into site to see issue as languages are hidden
hidden link

I expected to see:
localized text.

Instead, I got:
Source text is removed from site and is not displaying. please see screenshots

I can see the translations in the Theme Customization preview

June 13, 2019 at 11:17 am #4012295

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Simon,

Can you whitelist my IP (94.206.220.148) so I can access your website, please? I know that we had this little issue before and all I had to do is give you my IP address. Can you take care of this little change, please?

Thanks,
Radu

June 14, 2019 at 8:07 am #4019099

simonH-30

Hi Radu, can you try again now please.

June 14, 2019 at 10:09 am #4020289

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Simon,

Thank you for taking care of this. I could access the website now.
I remember that things were working fine the last time I checked your website (and still look fine when it comes to the settings, as you said). Can you tell me if you made any changes in the meantime (like changing the homepage, updating the theme or the plugins), please? This way I can try to check a certain option or area.

Thanks,
Radu

June 14, 2019 at 10:48 am #4020701

simonH-30

Hi Radu,

The homepage as never worked correctly the homepage text was appearing in English even though the admin strings were translated. We had used a child theme "Vistatec" of the Cleanporfoliopro Theme but this as causing issues so we changed back to the CleanporfolioPro theme. Note we have updated to the latest version of the theme recently but we get the same issue before and after the theme update. The homepage text appearing in English, when we select the language the text disappears.

Note when we disable the WPML String translation plugin, the English text appears on the homepage for all languages.

Regards.

June 17, 2019 at 8:56 am #4033499

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Simon,

The String Translation plugin is the one that "recognizes" the strings from the database (like the ones that are saved in the customizer) and make them available for translation. So having the same content over all the homepages when deactivating the plugin makes totally sense.

Now, regarding the content from the homepage, is there any chance that you could send me a copy of the theme? I just want to create a clean install, add the theme to it, and see if I can replicate this issue. As I can see, CleanPortfolioPro is not a part of our WPML compatible themes list (https://wpml.org/documentation/theme-compatibility) but maybe there's something I can do to sort this out. But for that I need to create a clean install and check things a bit closer.

Thanks,
Radu

June 18, 2019 at 8:05 am #4041157

simonH-30

what's the best way to send you the theme?

June 18, 2019 at 9:06 am #4041785

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Simon,

You can upload the theme to Google Drive or Dropbox, for example, and attach here the link. I set the next reply to be private so other users can't see the link (and download the theme).

Thanks,
Radu

June 18, 2019 at 12:46 pm #4043901

simonH-30

Hi Radu,

I placed it on the FTP you should have details form earlier thread in the folder webspace/httpdocs/theme/

June 19, 2019 at 8:40 am #4049611

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Simon,

Can you tell me where I can edit the content from the homepage from, please? I know that I was able to see that content on Customizer before but now I checked all the sections I can no longer see where to edit the content. Can you tell me what's the section I should look at, please? I installed the theme on my side and now I just need to check this out.

Thanks,
Radu

June 20, 2019 at 10:39 am #4058949

simonH-30

Hi Radu,
It's under Appearance/Customize/Theme Options/Service.

Regardss

June 20, 2019 at 1:31 pm #4060189

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Simon,

I copied the text from your website on my test site and everything works fine when checking the secondary language. You can have a look here: hidden link (the language switcher is at the bottom side).
Can you tell me if there any other caching you're using on your website, except for W# Total Cache that's already deactivated? Also, please update all the WPML plugins to the latest versions and tell me if the translation is still not working.

Thanks,
Radu

June 26, 2019 at 9:21 am #4090811

simonH-30

Hi Radu,

We have done what you've suggested but still have the same issue.

Regards,
Ian

June 28, 2019 at 9:39 am #4106207

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Simon,

Can you tell me if you changed the admin link, please? I'm asking this because I checked your website and I could see that now there's only one language available. When I tried to access the dashboard link again, I received a Error occurred: 403 - forbidden. Can you check this out, please?

Thanks,
Radu

July 3, 2019 at 8:47 am #4133523

simonH-30

Hi Radu,

Nothing has changed on our side have you changed your ip, do we need to add another IP to the white list?

The topic ‘[Closed] Theme admin string disappearing when switching langauges’ is closed to new replies.