This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 16 replies, has 2 voices.

Last updated by Mihai Apetrei 4 months, 2 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
May 28, 2019 at 6:38 am

simoneH-10

Hello,

I'm trying to change site identity value using theme customize option. When i changes that value and click on publish button then again i refresh it give old values rather than new ones. The issue is conflict with divi theme and WPML String Translation Plugin.

When i deactivate WPML String Translation Plugin it works fine i also contacted divi theme support and after 4 to 5 hours research they found that there is issue with WPML String Translation Plugin.

Thanks

May 28, 2019 at 11:01 am #3905921

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

1. Can you please create a full backup of the site and then go here (hidden link) and update everything to the latest version. Please see if the issue is still happening.

2. If the issue is still happening, please try this:

- disable all plugins except WPML and its add-ons (leave the Divi theme enabled)
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

3. If that doesn't solve the issue, please try this:

Your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased as the minimum requirement for WPML is 128Mb WP Memory Limit: https://wpml.org/home/minimum-requirements/

Please add this to your wp-config.php file to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so, if that’s the case, I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

Please let me know how that goes.

Also, make sure that you turn on any kind of caching that is enabled on the server or on the site.

If nothing from the steps above work, I will need to know from you what exact change are you trying to make and save inside the Theme Customizer and I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

May 28, 2019 at 11:46 am #3906403

simoneH-10

Hello,

I have alredy done steps you had provided and i also give you specification that your plugin WPML String Translation is causing issue and if i deactivate it then all things working fine.

Also i had provide you wp-admin detail and ftp details too.

So please let me know what actually the issue is and how to resolve it.

Thanks,

May 28, 2019 at 5:09 pm #3908981

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hello and thank you for your feedback.

At point 1, I was mentioning that there are a lot of plugin updates that are not installed yet and also the theme that you are using, Divi, has an update available, too, so the updates are not done yet and they can be found here:
hidden link

However, it seems what you are experiencing (if you are referring to the "Website/Site Identity" field) is not related to the updates that are not installed yet, but instead it is the expected behavior and it can be solved by following the solution in the link below:
https://wpml.org/forums/topic/site-identity-modified-in-original-language-not-modifiable-in-translated-langua/

Please follow the steps in the solution from the ticket link I shared with you above and let me know if that solves the issue.

I will be waiting for your response.

Kind regards,
Mihai

May 29, 2019 at 7:27 am #3912351

simoneH-10

Hello,

As per your suggestion i go to WPML -> String Translation and Translated both strings "SITE TITLE" and "SUBTITLE" but still its not working.

Scenario We have Tried :

Go to Theme Customizer -> changed both fields and click on publish button then refresh page its showing old values rather then it has to store new values.

Hope you got my concern and also plugins and divi theme updated to.And again i'm saying that issue is with wpml string translation plugin as if we deactivate it then all working good.

Thanks,

May 29, 2019 at 3:40 pm #3917015

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for following those steps.

From what I can see, you are using Yoast SEO, so even if in the Theme Customizer, under the "Site identity" section you see "Youki - Your Next Level", it seems that if you go to edit the homepage default language (hidden link), there is another text that is being used on the site instead of that one and that is "Youki | Specialist in mindfulness" (you should be able to find it at the bottom, in the Yoast SEO fields).

So if that is what you are referring to, in order to translate that, you would need to use the "Yoast SEO Multilingual" plugin that you can download from under your WPML.org account > the Downloads section (https://wpml.org/account/downloads/).

Also, here you can find out more about the process that needs to be followed:
https://wpml.org/documentation/plugins-compatibility/using-wordpress-seo-with-wpml/

Can you please let me know if that is what you are referring to?

If it is not, can you please elaborate a bit more on what strings you are trying to translate exactly and where should they show up on the site?

Please let me know.

There are big chances that I did not understand good enough yet what exactly you are trying to accomplish.

I will be waiting for your response.

Kind regards,
Mihai

May 30, 2019 at 2:02 pm #3923629

simoneH-10

Hello,

Go to themes -> customizer then try to edit site identity and subtitle then click on save changes and then refresh that page.

You will see the old value rather then updated value and the issue is the `WPML String Translation` Plugin if you deactivate it and follow above steps it will work fine.

So Divi theme and plugin are conflicting thats why its not working.Hope you got the issue and resolve as soon as you can.

Thanks,

May 31, 2019 at 9:13 am #3928837

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I tried what you recommended and for me, it seems that it works fine.

Please take a look over the video here:
hidden link

I hope that you will find this video helpful.

Just a note that I don't work on the weekends so I will be able to get back to you at the beginning of next week in case you write me back tonight or this weekend.

Kind regards,
Mihai

May 31, 2019 at 10:19 am #3929721

simoneH-10

Hello,

Now the Other issue arise as i have never seen this previously if you go to admin panel our default language is Dutch and if dutch selected still all admin menus and everything is in english thats new issue which was not previously and also in frontend of website whatever the language either dutch or english it shows pages always in english.

This is newer issue that coming first please help to resolve it as it was new one then we will check about theme customizer.

Thanks,

May 31, 2019 at 10:30 am #3929755

simoneH-10

Okay you have added language as english in profile so its showing that language thats not issue but still theme customizer issue persist.

Please take a look at video :
hidden link

Also note that you have to change this in dutch language and don't go to other page refresh that screen again.

Thanks,

May 31, 2019 at 3:23 pm #3931545

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Now I understand what you mean regarding the initial issue.

So, first of all, from my understanding, there is also a different issue happening.

In our forum, we try to keep one issue per ticket.


Continuing with one issue per ticket helps not only supporters to focus on one issue at once, but also enables other users to find solutions to their questions faster.

So may I kindly ask you to please open a new ticket for the additional issue you mentioned?

Thank you for your understanding.

Now, let's get back to the initial issue that we started this ticket with:

So, the way things work is that the only way to translate those 2 fields from Site Identity will be through WPML > String Translation.

As you will see, the text won't change in the Theme Customizer panel, but that is because that's how Divi is working with WPML at the moment and probably for them to have the text change there, too (just for you to see it there, too), they would need to do some custom implementation.

However, if you translate the fields through WPML > String Translation, you will see that the text is changing correctly at the top left of the site (the Nederlands language backend), only in the Theme Options Customizer panel, it will still look in English.

So from a functionality perspective, that works just fine. But, of course, if you would like to see it changed there, you would need to contact the Divi support theme and ask them to implement the translation in a way where you can also see the content update in the theme panel itself.

For the moment, the only way to translate it is the one I am presenting above:

- Go to WPML > String Translation
- Filter by "WP" domain
- You will see there are only 2 results which are the exact fields that you want
- Just update the translation with the one that you want, check the box and then save the translation

And that would be all you would need to do.

I am attaching a screenshot so that you can see how it works.

I hope that you will find this information helpful.

Kind regards,
Mihai

June 3, 2019 at 9:17 am #3940713

simoneH-10

Hello,

Thanks for guiding but i already know that its reflecting change to database in this term i agree but our concern is that why that changes not reflecting directly when i click on save changes and refresh the page.

Above is case one and you are point that divi theme has issue but their support told that issue is with plugin of wpml called `WPML String Translation` and i confirmed that when we deactivate the plugin things working fine and on refresh new value shows perfectly.

Please try to deactivate that plugin and check for the issue you got the answer.Hope you understand what i mean here.

Thanks,

June 3, 2019 at 5:01 pm #3944719

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Yes, I totally understand what you mean.

I understand that it happens when WPML String Translation is active, however that doesn't affect any functionality and my guess is that this might be a compatibility issue.

Another thing I can do is that if you are able to recreate the issue on our testing servers, too, I can also send this to our developers from the Compatibility department, however I can't give an estimate of when this will be taken care of (in case it will be confirmed that it is happening on our testing servers, too) as they are deciding the priorities of each of the issues they are working on at the moment.

I have created this sandbox clean testing environment here (one-click login):
hidden link

All I would need from you is to set up WPML as you have it on your site (WPML and the add-ons are already installed on the site) + install&setup the theme and recreate the issue.

Please let me know how that goes and if the result is the same even on a clean install where our purpose is to use as fewer plugins as possible (just the WPML plugins and the theme that you are using), then I can forward it to the Compatibility department.

I will be waiting for your response.

Kind regards,
Mihai

June 4, 2019 at 5:13 am #3948021

simoneH-10

Hello,

In demo which is set up by you we have configured all plugins as they are in our live website so now you can debug and fix the issue.

Hope it will be fixed soon as site is live.

Thanks,

June 4, 2019 at 2:30 pm #3952745

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I checked the sandbox I created for you but all I can see is that WPML was set up.

However, what I am currently still missing from you is this part "install & setup the theme and recreate the issue."

I don't have the theme that you are using so I would practically need you to install it (the bare minimum, no other unnecessary plugins), configure it normally like you have it on your site and then try to recreate the issue on our servers, too.

After that, if the issue is still happening on our servers, I can forward it to our Compatibility department.

Please let me know when that's done so that I can have a look.

I will be waiting for your response.

Kind regards,
Mihai