This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 22 replies, has 2 voices.

Last updated by Bobby 1 month, 4 weeks ago.

Assigned support staff: Bobby.

Author Posts
August 6, 2019 at 9:51 pm #4350559

julieC-6

I am trying to: use my 'wpml compatible theme'.

Link to a page where the issue can be seen:

I expected to see: The custom short codes to be accepted by WPML and viewable in the page translator.
hidden link

I even tried manually adding the Total xml file into their settings panel here:
hidden link – and that’s not registering the custom shortcodes either.

Since everything is done in the theme according to their documentation if it’s not working it would suggest it’s an issue in the plugin itself (maybe with a recent update).

Instead, I got: they aren't being seen and can therefore not translate them.

August 6, 2019 at 11:09 pm #4350743

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

1. which version of the Total Theme are you currently using ?

i have done a quick test on my testing environment and it is working as expected with

vcex_heading: text

picked up by the Translation Editor.

2. are you using the classsic Translation Editor or the Advanced Translation Editor ?

August 7, 2019 at 4:08 pm #4356689

julieC-6

Hi there - it doesn't work for me nor the theme developer. He's using the latest, I'm using one back.
[vcex_heading text="Our Products" doesn't show up in the Page translation:

2. what is classic Translation Editor vs Advanced? I'm using the one that is accessed through the pages dashboard. see the attached.

August 7, 2019 at 6:06 pm #4357277

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for updating me ,

If possible i would like to take a closer look at the backend to further test this issue

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

August 9, 2019 at 2:45 am #4366821

julieC-6

Hi Bobby - ok. Could you also answer my second question - what's this classic v advanced?

[removed]

August 9, 2019 at 4:29 pm #4371891

julieC-6

hey! that was not sent privately - I had to delete the user because even though it says it was private, it was viewable without logging in with my login on WPML. Anyone could have logged into the admin.
If you need access - please make sure it is not viewable publicly.

August 9, 2019 at 4:31 pm #4371895

julieC-6

it wouldn't be hard to figure out the url as it is listed at the top of the page.

August 9, 2019 at 7:03 pm #4372557

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

i apologize for this not sure what happened , i have test the private field and it should work as expected.

if you wish you can share with me the access through email [removed]

(do make sure you reply here once done so i am notified please )

To answer your question :

the WPML Classic Translation Editor is our side to side editor , on the left is the default language and on the right is the translation

=> https://wpml.org/documentation/translating-your-contents/using-the-translation-editor/

the WPML Advanced Translation Editor is our machine translation editor please read more about it here

=> https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/

August 9, 2019 at 7:44 pm #4372683

julieC-6

I've sent you information over email - though that's not secure either so I'm a bit uneasy.

yes, I'm using the classic editor. the advanced editor isn't great because it seems to do a lot of things I don't need and we are avoiding all machine translation.

If you could please please have a look here at the site ASAP. I've been trying to get this resolved for going on 4 days now and it's really putting me in a bad position. I have a deadline on the 12th.

August 9, 2019 at 8:21 pm #4372935

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

thank you, taking a look at this right now

will update you shortly

August 9, 2019 at 10:36 pm #4373075

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

I was able to successfully register the shortcode testing on a staging environment using your duplicator package

an issue that i noticed was that you are currently using the WPML Translation Management version 2.8.6.1 , that particular version had some missing libraries which is why when adding your custom-xml it was still not working

i have tried updating the translation management plugin from within Plugins->Add new->commercial tab -> check for updates and update WPML Translation Management and at the moment it looks like it shows me the following 503 error "Briefly unavailable for scheduled maintenance. Check back in a minute."

please make sure that you update WPML Translation Management to 2.8.6.2 and then go to WPML->Settings->Custom XML configuration and add the following

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>vcex_heading</tag>
            <attributes>
                <attribute encoding="allow_html_tags">text</attribute>
                <attribute type="link" encoding="av_link">link</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

once done add new page -> add heading and set it to "testing heading" (make sure you add a new string for the heading and dont leave it empty) -> update and add new translation , you should be able to see it register

August 12, 2019 at 5:16 pm #4382709

julieC-6

Hi Bobby,
This weekend I was able to get the plugin to update and made those xml changes as instructed. However, it still didn't pick up the custom Total headers and content. For example, after I followed your steps, I did that searching for links which took over two hours. It found 115 repaired links out of over 80k strings. But it didn't pick up the text content that was missing.

The homepage of the site has a Header of 'Our Products' - that doesn't show up in the classic editor. There are teaser boxes with headers and body copy (the circle images) - those also are not picked up by the classic editor.

What can we do to get those into the translation editor?

Thank you,

August 12, 2019 at 5:41 pm #4382855

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

i have accessed the backend of your site and i can confirm that WPML Translation Management is still showing as the older version and deactivated.

did you test updating it on this site or another environment ?

August 12, 2019 at 6:07 pm #4383027

julieC-6

I did it on the current site, but then had to revert to a backup due to the site going down.
I'm now working on the staging site to avoid such issues.
That site has the updated plugin and activated.

could we trouble shoot that there and it's not such a risk?
I will need to email you a new password and user

August 12, 2019 at 8:15 pm #4383531

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

great!

i have received the email , will update you soon