This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Ahmed Mohammed 5 years, 8 months ago.

Assigned support staff: Ahmed Mohammed.

Author Posts
July 30, 2014 at 2:14 pm #444772

Harold

Hello,
I'm trying to translate my theme so that it will fit the language used for the content.

Anyway, only the first 3 string (all being in header.php file) are properly translated, with all the others being left in original language.

When analyzing my theme, WPML finds 35 strings (which is the correct number), tells they've been added to the translation panel, but I only find the first 3.

Any help appreciated,

Thanks.

July 30, 2014 at 2:38 pm #444787

Ahmed Mohammed
Supporter

Timezone: Europe/Rome (GMT+01:00)

Hello Harold,

Thanks for contacting us, I'll help in this.

# Can you post a screenshot of your WPML-> Support page ?

# Please post your theme name, version and link if any.

# Let's check these setting for better understanding the problem
- Under WPML-> Theme and plugins localization, make sure it has been set to Translate by WPML
- Under WPML-> String Translation, scroll down and make sure Track where strings appear on the site is disabled.
- Disable auto-register strings.
- Original Language of Strings is English
- Then go to WPML -> Support -> Troubleshoot page -> Execute the following :
* Remove ghost entries..
* Set Language Information
- Then go back to WPML-> Theme and plugins localization -> Scan theme for strings and check if the problem exists.

Regards,
Ahmed

The topic ‘[Closed] Theme localization not fully working’ is closed to new replies.