This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by marcov-39 12 months ago.

Assigned support staff: Diego Pereira.

Author Posts
October 4, 2018 at 12:10 pm #2787444

marcov-39

When I try to save the theme options in Avada it can be only for each language not for all languages. I took over the site and I am transfering Avada into the site. Now I have to edit theme options. I want to change the optioons in the All languages mode so I can set them once. How can I do this?

Marco

October 5, 2018 at 4:55 pm #2791379

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @marcov-39, welcome to the WPML support Forum!

please try the following:
- On the WP Dashboard, go to the theme options
- Select "All Languages" on the Language Switcher at the top admin bar
- Edit the options and save

Please let me know if it worked for you.

I also checked the settings of your server through debug log and saw that some items need attention:
Increase WP memory
Please increase the PHP memory limit to 256mb. Currently this memory is set to 40mb only.
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

MaxInputVars
Currently your server is configured with MaxInputVars = 1000, which is too low and can cause problems. Please increase this to 10,000. There are two options to do this:
== php.ini file
Open the php.ini file and insert/edit this line:

max_input_vars = 10000

hidden link
== .htaccess file

php_value max_input_vars 10000

All the best,
Diego

October 10, 2018 at 3:42 pm #2805041

marcov-39

Hi,

Sorry for the delay. I am very bussy with a lot of customers. I changed everything you said but still it is not working. What to do now?
I did already do the all language before but then it didn't work either. New suggestions please? 🙂

Marco

October 11, 2018 at 8:46 am #2807209

marcov-39

I see in other forum topics this problem is already known from 2016. Why didn't you get this sorted out? Avada is one or maybe the biggest theme in WordPress.
But I also read about the in between solution to export and import settings. Would be nice that you had know this too.

I hope to hear from you with a time estimate when there will be a working WPML plugin.

October 11, 2018 at 11:38 am #2807974

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello Marco,

I understand, we are working to improve compatibility with all themes but in fact this compatibility depends more on how the theme is coded than on WPML. Could you send us the link of theses tickets? I will take a look.

According to their documentation, the all languages option should work:
hidden link

If it is not working like the documentation, the procedures are:
- Reproduce the issue in a clean install to isolate and check the compatibility issue. If found, we forwarded to our compatibility team to correct with the authors of the topic.
- If the same problem does not occur in a clean install, we need to keep investigating to find out why it is not working on your website.

I created a test website with a clean WordPress install. You can access it through this link:
hidden link - Through this link you will be automatically logged in.

Please upload the theme to this test install and setup it the same way as in your website (using the same options) and try to reproduce the issue. Please note that we only need the theme, the related functionality and some dummy content, you don't need to setup a entire website or clone your existing site.

Kind regards,
Diego

October 11, 2018 at 11:58 am #2808024

marcov-39

Here are two I found
https://wpml.org/forums/topic/theme-options-avada-did-not-get-copied-to-new-languages-at-install-of-wpml/
https://wpml.org/forums/topic/wpml-doesnt-recognize-avada-theme-settings-in-secundary-language-site/

I was wondering if it could have to do something with use of a subdomain? hidden link

I have only 5 plugins and these are fusion builder and core of Avada, contact form, yoast SEO and revolution slider. These are all pretty well build plugins. I don't think the problem will lay here?

The problem is that I am on a time schedule and have to deliver a website translated this week. Now I have to test something that should work. Sorry that I am so cranky but I think it just have to work wouldn't it. Now it will take me a lot longer.
I also notice that I can't change the template of pages for all languages. It will go back to default settings.
I can give you access to the site.

Marco

October 11, 2018 at 6:27 pm #2809460

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks. Have you tested the export/import workflow? It worked on your website?

I don't think this is related to the subdomain. If you want, we can duplicate your website and run some tests with the theme options to check if there is a quick solution. But if we don't find it, we still need to isolate the issue on the clean install to check compatibility. We will do our best to find a solution ASAP, but unfortunately we can not promise that we will find the solution this week (it's almost friday).

Please send us access to your WordPress dashboard (website URL, login and password) and the steps to reproduce the issue. We'll check and do some tests. - Please use the private field to send the sensitive data - do not post if you do not see it.

It would be better if you give me a test site rather than the live site.

IMPORTANT Please backup a working copy of site files and database before.

Maybe we'll need to replicate your site. For this please temporarily install a plugin called “Duplicator” and "Cloudways WordPress Migration" on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the copy site. Please let me know if this is ok for you.

Regards,
Diego

October 15, 2018 at 11:31 am #2817158

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @marcov-39,

Sorry for the delay, I was off on Friday and we had a big load of tickets, so my colleagues could not cover me. I'll prioritize this ticket so that we can find a solution faster.

Unfortunately the credentials are not working (ERROR: Invalid username), could you please check?

Kind regards,
Diego

October 25, 2018 at 11:08 am #2849513

marcov-39

Forget the special login "inloggenwebsite" make it "wp-admin" again

October 25, 2018 at 2:37 pm #2850149

marcov-39

Strange thing is that I have almost the same installation with Avada and it is working just fine.

October 25, 2018 at 7:46 pm #2851015

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks! What happens is that when a setting is set in a specific language, it will overwrite what is set in "All languages".

I did the following tests at your website:
- On Avada > Theme Options, I clicked on Reset All. So all options are set as the default demo ( >> don't do that on the live website, you will loose all settings <<).
- I modified some options like colors and header format. The modifications have been applied to all languages.
- At the "Phone Number For Contact Info" field, I set "All languages text". This text was applied to all languages
- I Changed the language to "Dutch" and modified this text to "Dutch text to overwrite the All languages settings"
- Now the English and German pages display the previous text. Only the Dutch page displays this new text.
- I changed back to "All languages" and changed the text to "All languages text 2"
- This modification was applied to all pages, but the Dutch page.

You can check here:
- hidden link
- hidden link

So, if you need to use some setting from the All Languages, you should go to the specific language and empty that field, so it will load the setting from the "All Languages". You can also try the "Reset Section" for this.

IMPORTANT: Please backup your site first before making any change, this is important for security reasons.

Please let me know if it worked for you.

Regards,
Diego

October 26, 2018 at 1:57 pm #2853209

marcov-39

My issue is resolved now. Thanks Diego for your presistent attitude Thank you!